Решить по информатике 8 класс
программу напишу я сам, но вот как решить ее? по заданной дате надо сразу сказать кто победит, тойсть если называть одно и тоже число всегда будет побеждать тотже игрок
играют двое. задаётся какая-то дата 2020 года. каждый игрок на своём ходе называет более позднюю дату, увеличивая на 1 или 2 либо день в месяце, либо месяц, но не то и другое сразу. при этом сочетание дня и месяца должно оставаться датой. игрок, назвавший 31 декабря, проигрывает. оба играют наилучшим образом. исходя из заданной даты вывести, кто выиграет.
входные данные
в первой строке находятся числа, обозначающие день и месяц.
выходные данные
вывести 1, если выигрывает первый (начинающий) игрок, или 2 - в противном случае.
примеры
входные данные
30 12
выходные данные
2
#include <iostream>
using namespace std;
// функция с алгоритмом двоичного поиска
int Search_Binary (int arr[], int left, int right, int key)
{
int midd = 0;
while (1)
{
midd = (left + right) / 2;
if (key < arr[midd]) // если искомое меньше значения в ячейке
right = midd - 1; // смещаем правую границу поиска
else if (key > arr[midd]) // если искомое больше значения в ячейке
left = midd + 1; // смещаем левую границу поиска
else // иначе (значения равны)
return midd; // функция возвращает индекс ячейки
if (left > right) // если границы сомкнулись
return -1;
}
}
int main()
{
setlocale (LC_ALL, "rus");
const int SIZE = 12;
int array[SIZE] = {};
int key = 0;
int index = 0; // индекс ячейки с искомым значением
for (int i = 0; i < SIZE; i++) // заполняем и показываем массив
{
array[i] = i + 1;
cout << array[i] << " | ";
}
cout << "\n\nВведите любое число: ";
cin >> key;
index = Search_Binary (array, 0, SIZE, key);
if (index >= 0)
cout << "Указанное число находится в ячейке с индексом: " << index << "\n\n";
else
cout << "В массиве нет такого числа!\n\n";
return 0;
}
12
Объяснение:
Импликация A → B неверна только в том случае, когда посылка A истинна, а следствие B ложно.
Значит, не должно найтись таких x, что ¬ДЕЛ(x, 18) (то есть, x не делится на 18), (¬ДЕЛ(x, A) → ¬ДЕЛ(x, 12)) ложно.
¬ДЕЛ(x, A) → ¬ДЕЛ(x, 12) ложно, если ¬ДЕЛ(x, A) (x не делится на A) и неверно, что ¬ДЕЛ(x, 12) (то есть, если x делится на 12).
Собираем вместе:
Не должно найтись таких x, для которых одновременно x не делится на 18, x не делится на A и x делится на 12.
Если x делится на 12 = 6 * 2 и не делится на 18 = 6 * 3, то оно точно делится на 12, и не факт, что делится на что-то большее. Значит, максимально возможное значение A - 12.