В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ёлкап
ёлкап
05.05.2022 02:51 •  Информатика

Решить по ПИТОНУ две задачи 3. Вам дана строка «Благотворительность». Составьте программу, которая из данной строки составит новую строку «отвратительно».

4. Написать программу, которая находит произведение первых А натуральных чисел. Число А вводится с клавиатуры.

Показать ответ
Ответ:
салмик
салмик
18.02.2021 17:50
1:
Вес текста = 59 * 16 бит = 944.0 бит = 118.0 байт = 0.115234375 Кбайт = 0.0001125335693359375 Mбайт
2:
Вес текста = 16 * 30 * 32 * 16 бит = 245760.0 бит = 30720.0 байт = 30.0 Кбайт = 0.029296875 Mбайт
3:
Вес символа = 25 * 8 * 1024 бит / (8 * 40 * 64 бит) = 10.0 бит
4:
Вес текста = 1024 * 64 * 64 * 8 бит = 33554432.0 бит = 4194304.0 байт = 4096.0 Кбайт = 4.0 Mбайт
5:
Вес текста = 52 * 16 бит = 832.0 бит = 104.0 байт = 0.1015625 Кбайт = 9.918212890625e-05 Mбайт
6:
Вес текста = 16 * 35 * 64 * 8 бит = 286720.0 бит = 35840.0 байт = 35.0 Кбайт = 0.0341796875 Mбайт
0,0(0 оценок)
Ответ:
nobos9n
nobos9n
17.04.2021 17:27
// PascalABC.NET 3.2, сборка 1345 от 24.11.2016
// Внимание! Если программа не работает, обновите её версию!
begin
  var Z:=ArrRandom(ReadInteger('n='),1,99);
  Writeln('Массив Z'); Z.Println;
  Writeln('Массив X');
  var X:=Z[1::2].Select(p->p/2).ToArray; Swap(X[0],X[X.Length-1]);
  X.Println;
  Writeln('Массив Y');
  var Y:=Z[::2].Select(p->p/3).ToArray; Swap(Y[0],Y[Y.Length-1]);
  Y.Println
end.

Пример
n= 8
Массив Z
74 17 35 3 33 84 48 39
Массив X
19.5 1.5 42 8.5
Массив Y
16 11.6666666666667 11 24.6666666666667
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота