В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Medvedevatanya1
Medvedevatanya1
19.05.2021 00:52 •  Информатика

Решить по с++ : пользователь вводит с клавиатуры 7 целых чисел. написать программу, которая определяет максимальное из этих 7 чисел(через if, else).

Показать ответ
Ответ:
булати
булати
07.10.2020 16:34
#include <iostream>

using namespace std;

int main()
{
  int a[7];
  int MAX = -1000*1000*1000-13;
  for (int i = 0; i < 7; ++i)
    cin >> a[i];
  if (a[0] > MAX)
    MAX = a[0];
  if (a[1] > MAX)
    MAX = a[1];
  if (a[2] > MAX)
    MAX = a[2];
  if (a[3] > MAX)
    MAX = a[3];
  if (a[4] > MAX)
    MAX = a[4];
  if (a[5] > MAX)
    MAX = a[5];
  if (a[6] > MAX)
    MAX = a[6];
   cout << MAX;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота