Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
belozerovyurik
27.07.2020 09:35 •
Информатика
Решить с использованием подпрограммы. заменить данное натуральное число на число, которое получается из исходного записью его цифр в обратном порядке (например, дано число 156, нужно получить 651)
Показать ответ
Ответ:
Ангелина22325
20.08.2020 06:38
Var
N:integer;
procedure Change(var n);
var
n2,n3,i:integer;
begin
i:=1;
n2:=n;
n:=0;
while n2>0
begin
n3:=n2 mod 10;
n2:=n2 div 10;
n:=n*i + n3;
i:=i*10;
end;
end;
begin
readln(N);
Change(N);
writeln(N);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
borshliba
28.06.2021 09:48
Надо написать программу...
Армения1234566
29.01.2020 23:29
Напишите, программу для о прямоугольнике: даны 2 стороны прямоугольника a и b. найти его периметр и площадь. (язык программирования pascal)....
Вероника13411
25.11.2020 05:21
Отметьте верные утверждения, которые относятся к условно бесплатному по. можно выбрать несколько вариантов ответа. a) программы, которые полностью функциональны...
marat20172003
23.03.2022 00:04
Вкодировке кои-8 каждый символ кодируется одним байтом. определите количество символов в сообщении, если информационный объём сообщения в этой кодировке равен 80...
зяйка75542
26.07.2022 11:27
Полный путь файлу : c: \books\raskaz.txt.каково имя файла...
gmurzakaevap06yh1
01.12.2022 09:50
Упорядочите следующие числа по убыванию: 61*10, 73*8, 111111*2, 46*16....
аовлвововоов
01.12.2022 09:50
Запишите наибольшее пятизначное число в двоичной системе счисления и определите его десятичный эквивалент....
умно55567
29.09.2021 18:56
Закодируйте в двоичной форме свою фамилию, записанную латинскими буквами, используя таблицу кодировки ansi. (20 ) закодируйте короткую фразу на языке. укажите таблицу...
elshad2003
29.09.2021 18:56
Решить нужно решение словесное описание алгоритма сложения двух обыкновенных дробей a/b и c/d...
DedikovVladisl
29.09.2021 18:56
Тест кодирование информации . для представления текстовой информации в компьютере специальные коды, которые называются: a) символьными ; b) текстовыми ; c) текстовой...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
N:integer;
procedure Change(var n);
var
n2,n3,i:integer;
begin
i:=1;
n2:=n;
n:=0;
while n2>0
begin
n3:=n2 mod 10;
n2:=n2 div 10;
n:=n*i + n3;
i:=i*10;
end;
end;
begin
readln(N);
Change(N);
writeln(N);
end.