Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
aslazer211124
09.05.2023 23:17 •
Информатика
Решить с паскаля в заданном слове подсчитать количество сочетаний "ое", а если их нет то к слову приписать это же слово.
Показать ответ
Ответ:
никуся1984
21.07.2020 17:59
Program prog;
uses crt;
var s: string;
i,k: integer;
begin
clrscr;
write('Введите S = ');
readln(s);
for i:=1 to (length(s)-1) do
if s[i]+ s[i+1]= 'ое' then k:=k+1;
if k>0 then
writeln('Количество сочетаний "ое" k = ',k)
else begin
writeln('Cочетаний нет');
writeln(s+s);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
kasoimandarin1
10.02.2023 00:41
Группа слов,которая выражает законченную мысль...
пельмешик2
21.02.2022 14:54
Восстановите IP-адрес по фрагментам. В ответе укажите последовательность букв, обозначающих фрагменты, в порядке, соответствующем IP-адресу. А. 6.51 Б. 53.1 В. 19 Г. 3.2 Решение...
alinanamcat12
14.11.2022 14:20
Для записи текста использовался 64-символьный алфавит. какой объём информации в байтах содержат 10 страниц текста, если на каждой странице расположено 32 строки по 64 символа...
алмаз122
25.02.2023 02:53
A: =-(2+3*(10-7)) b: =(22/a)*(33/a) b: =b/2 информатика кто-нибудь решите...
taitpaev2003
14.09.2022 04:00
Раздел описания перемнных начинаются со слова...
T1shka136
09.12.2021 00:55
# Пользователь вводит с клавиатуры целое число. # Написать программу, которая определяет является ли число простым или составным. # Число является простым, если делится только на...
аринка129
12.07.2020 15:08
Які зміни необхідно внести до скрипта проекту, щоб відбувалася перевірка 6-значних чисел? ...
Ravik2K
29.04.2021 03:00
Write sentences. use too or not enough and the adjectives in brackets. this room is too cold.(warm) this room isnt warm enough. 1)i m not rich enough. (poor 2)this car is too slow....
Зл0йстудент
29.04.2021 03:00
Как притча о блудном сыне нашла отражение в повести ,,станционный смотритель...
Сова00478902500
29.04.2021 03:00
Фото синтез спирогиры в её клетках происходит в?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
uses crt;
var s: string;
i,k: integer;
begin
clrscr;
write('Введите S = ');
readln(s);
for i:=1 to (length(s)-1) do
if s[i]+ s[i+1]= 'ое' then k:=k+1;
if k>0 then
writeln('Количество сочетаний "ое" k = ',k)
else begin
writeln('Cочетаний нет');
writeln(s+s);
end;
end.