В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
zoeves
zoeves
30.12.2022 21:24 •  Информатика

РЕШИТЬ В ПАСКАЛЬ Дана строка, состоящая из слов (разбитых пробелами) и строка символов. Необходимо выяснить, можно ли из символов строки 2 получить слова из строки 1. Если можно, то вывести эти слова, иначе вывести NO. (буквы из набора можно использовать несколько раз)

Входные данные

Строка содержащая слова через пробел и строка с набором букв

Выходные данные

Слова, которые можно получить из символов второй строки или слово NO

For example:

Input Result
hello i love you
ieohuyvl
hello
i
love
you

Показать ответ
Ответ:
амир250
амир250
23.01.2021 09:35

var s,s1,s2:string;

p,k:integer;

begin

readln(s);

s1:=s+' ';

while pos('  ',s1)>0 do delete(s1,pos(' ',s1),1);

while s1<>'' do

begin

p:=pos(' ',s1);

s2:=copy(s1,1,p-1);

delete(s1,1,p);

k:=1;

while pos(s2,s1)>0 do

begin

k:=k+1;

delete(s1,pos(s2,s1),p);

end;

if k=1 then writeln(s2);

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота