В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
DmitryKind98
DmitryKind98
16.09.2022 20:07 •  Информатика

Решить в паскале! однажды первокласснику вовочке задали сложить из спичек прямоугольник, и вычислить его площадь. с вовочка справился, однако заметил, что из одного и того же количества спичек можно сложить разные прямоугольники, а иногда, чтоб сложить прямоугольник, не удается использовать все спички. например из 14 спичек можно сложить прямоугольники со сторонами 1 и 6, 2 и 5, 3 и 4. естественно, вовочке хочется сложить прямоугольник максимальной площади, но это для него слишком сложная . напишите программу, которая по данному количеству спичек определит, какой максимальной площади можно составить прямоугольник из этих спичек (спички ломать не разрешается)

Показать ответ
Ответ:
валерия821
валерия821
06.10.2020 23:32
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество спичек:');
  var (n2,n4):=(n div 2, n div 4);
  Writeln('Максимальная площадь: ',n2=2*n4?n4*n4:n4*(n4+1))
end.

Пример
Количество спичек:1 4
Максимальная площадь: 12
0,0(0 оценок)
Ответ:
89196252139139
89196252139139
06.10.2020 23:32
Var a,b,n,max: integer;
begin
max:=0;
write('Количество спичек: ');
readln(n);
for a:=1 to n div 2 do 
begin
for b:=a to n div 2 do
begin
if (a*b>max)and ((2*a)+(2*b)<=n) then
max:=a*b;
end;
end;
write('Максимальная площадь: ',max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота