Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
nezandenzar
27.05.2020 10:06 •
Информатика
Решить в паскале перевести заданное количество байтов в биты, килобайты, мегабайты.
Показать ответ
Ответ:
Кашмамининагений
01.10.2020 13:52
Program Calculator;
var b, kb, mb, bt: real;
begin
write('Введите количество байтов: ');
readln(b); {bytes}
kb:=b/(1 shl 10); {kbytes}
mb:=b/(1 shl 20); {mbytes}
bt:=b*8; {bits}
writeln(bt:1:2, ' - битов ',kb:1:2, ' - килобайтов ',mb:1:2, '- мегабайтов ');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
msvladimirovnalena
31.05.2023 04:31
Участвую в одном конкурсе,делаю презентацию, но не знаю нужно ли писать в конце за внимание (я отправляю его, а не показываю) 35...
elviraborysenko
23.03.2021 13:50
Требуется написать программу, которая по заданным значением a, c, d и k находит значение выражения (a+(d−12)⋅3)⋅(c−5⋅k)....
Liliya35381
01.06.2021 12:03
35 .дан массив 3x4.найти кол-во четных элементов массива.вывести исходный массив на экран. надо поподробней написать и в turbo pascal(турбо паскаль 100%)...
1007199
07.09.2021 13:32
В данных записях найдите коды ASCII трех знакова) 1010010010110101101111101...
evaalmazova
22.03.2021 18:24
Что нарисует Черепашка?повторить 44вперед 150налево 90)...
toshaantoshai
30.03.2022 15:10
Сторану квадрата увеличили на 15%.на сколько процентов увеличится полощадьквадрата?...
huxgehd
30.03.2022 15:10
Фонвизин, недоросль . сформулируй идею произведения ( основную мысль)...
Alla123489
30.03.2022 15:10
Вставьте слово : этой сладости я рад - разноцветный ! разгадайте загадки : 1. в моей спинке есть монетки . тебе - купи конфетки . 2. худеет с каждым днём толстяк и не поправиться...
darinakydryash
30.03.2022 15:10
Написать на из 20фраз на тему спорт...
asdfghjkl12347
30.03.2022 15:10
Маятник с нерастяжимой нити длиной 25 см и небольшого шарика массой 100г подвешенной в космической ракете. какой период колебания маятника, когда ракета стартует вертикально с ускорением...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var b, kb, mb, bt: real;
begin
write('Введите количество байтов: ');
readln(b); {bytes}
kb:=b/(1 shl 10); {kbytes}
mb:=b/(1 shl 20); {mbytes}
bt:=b*8; {bits}
writeln(bt:1:2, ' - битов ',kb:1:2, ' - килобайтов ',mb:1:2, '- мегабайтов ');
end.