В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lele4
lele4
30.10.2020 17:21 •  Информатика

Решить в питоне (python) 11 !
надо написать программу, которая принимает текст и выводит два слова слова: наиболее часто встречающееся слова и самое длинное слово.

буду .

Показать ответ
Ответ:
Damirka1137
Damirka1137
17.08.2020 11:53

n = input()

n=n.replace("."," ")

n=n.replace(","," ")

n=n.replace("!"," ")

n=n.replace("?"," ")

n=n.replace("-"," ")

n=n.replace("("," ")

n=n.replace(")"," ")

n = n.split()

maxlength = ""

maxcount  = ""

for a in range(len(n)):

   if len(n[a])>len(maxlength):

       maxlength = n[a]

   if n.count(n[a])>len(maxcount):

       maxcount = n[a]

 

print("maxcount: "+maxcount)

print("maxlength: "+maxlength)

Объяснение:

есть нюанс:а что если 2 или больше слова которые может быть одинаково длиной какую должен выводит?

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота