В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
n254n
n254n
08.03.2020 19:23 •  Информатика

Решить в Python Написать программу вычисления стоимости покупки, состоящей из нескольких тетрадей и карандашей. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом) ВВЕДИТЕ ИСХОДНЫЕ ДАННЫЕ:

ЦЕНА ТЕТРАДИ (РУБ.) – > 2.75

КОЛИЧЕСТВО ТЕТРАДЕЙ – > 5

ЦЕНА КАРАНДАША (РУБ.) – > 0.85

КОЛИЧЕСТВО КАРАНДАШЕЙ – > 2

СТОИМОСТЬ ПОКУПКИ: 15.45 РУБ.

Показать ответ
Ответ:
Milanaмилана
Milanaмилана
20.04.2020 03:22
Var
A,B,C:integer;
Begin

WriteLn('Введите три числа');
ReadLn(A,B,C);
if (A<=B)and(B<=C) then Write(A,' ',B,' ',C)
else if (A<=C)and(C<=B) then Write(A,' ',C,' ',B)
else if (B<=A)and(A<=C) then Write(B,' ',A,' ',C)
else if (B<=C)and(C<=A) then Write(B,' ',C,' ',A)
else if (C<=A)and(A<=B) then Write(C,' ',A,' ',B)
else if (C<=B)and(B<=A) then Write(C,' ',B,' ',A)
End.

Var a,b,c,D:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
D:=b*b-4*a*c;
if D>=0 then
   Begin
   WriteLn('x = ',(-b-sqrt(D))/(2*a));
   WriteLn('x = ',(-b+sqrt(D))/(2*a));
   End
else WriteLn('Действительных корней нет')
End.
0,0(0 оценок)
Ответ:
den751
den751
31.07.2022 20:34
1
program z1;
var a,b,c,d, min1, min2, min:real;
begin
writeln ('Введите 4 числа:');
readln (a,b,c,d);
if a<b then
min1:=a
else
min1:=b;
if c<d then
min2:=c
else
min2:=d;
if min1<min2 then
min:=min1
else
min:=min2;
writeln ('Наименьшее число: ',min);
end.

2
program z1;
var a,b,c,d,g,k:real;
begin
writeln ('введите стороны треугольника:');
readln(a,b,c);
if a<b then
begin
k:=a;
d:=b;
end
else
begin
k:=b;
d:=a;
if d<c then
g:=c
else
g:=d;
if g*g=d*d+k*k then
writeln ('треугольник прямоугольный')
else
writeln('треугольник не прямоугольный');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота