решить задачи на пайтоне 1 Напишите программу, которая по данному числу n от 1 до 9 выводит на экран n зверьков. Между двумя соседними зверьками также имеется пустой (из пробелов) столбец. Разрешается вывести пустой столбец после последнего зверька. Для упрощения рисования скопируйте зверька из примера в среду разработки.
^---^
( o o )
! = !/)
ЗАДАНИЕ 1
1 Абу́ Абдулла́х (или Абу Джафар) Муха́ммад ибн Муса́ аль-Хорезми́ (перс. بن موسی خوارزمی, араб. أبو عبد الله محمد بن موسی الخوارزمی; ок. 783 — ок. 850) — среднеазиатский учёный IX века, математик, астроном, географ и историк. Благодаря ему в математике появились термины «алгоритм» и «алгебра».
2 Дж. Буль опубликовал работу «The Mathematical Analysis of Logic» («Математический анализ логики»), а в 1854 г.— «Ап Investigation of the Laws of Thought…» «Исследование законов мышления»). В них Буль изложил основы своей алгебры логики, где применил алгебраическую символику для записи логических операций и логических выводов. Булева алгебра логики в виде исчисления классов явилась первой системой математической логики. Основным результатом Булевой алгебры отмечается то, что теперь не ограничиваются применением символики к логике, а строят специальные логические исчисления; логические законы выступают в алгебре логики как необходимый момент формализованных систем.
3 Intel 4004 — 4-битный микропроцессор, разработанный корпорацией Intel и выпущенный 15 ноября 1971 года. Эта микросхема считается первым в мире коммерчески доступным однокристальным микропроцессором.
4 В 1820 году Шарль Ксавье Тома де Кольмар создал первое серийно выпускавшееся механическое счётное устройство — арифмометр Томаса, который мог складывать, вычитать, умножать и делить. В основном, он был основан на работе Лейбница.
Объяснение:
function fibonacchi(x:integer):integer;
// функция возвращает порядковый номер введённого числа
// ряда Фибоначчи. Если число не является элементом
// из данного ряда, то функция возвращает -1
var counter:integer = 2;
s1,s2,s3:integer;
begin
s1 := 0;
s2 := 1;
s3 := 0;
if x = 0 then fibonacchi:=1
else if x = 1 then fibonacchi:=2
else begin
while s3 < x do begin
s3 := s1 + s2;
s1 := s2;
s2 := s3;
inc(counter);
end;
if s3 = x then fibonacchi:=counter
else fibonacchi:=-1;
end;
end;
begin
write(fibonacchi(13));
end.