В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ivandawidov
ivandawidov
12.06.2020 20:37 •  Информатика

Решить задачи по программированию в Паскале АВС: 1. Иван любит играть в настольную игру Эрудит. Правила очень просты: из имеющихся букв нужно составлять слова и выкладывать их на игровое поле. Сейчас перед Иваном лежат несколько букв. Он придумал очень интересное слово и решил узнать, сколько таких слов он сможет составить из имеющегося у него набора букв.
Формат входных данных
В первой строке дана строка из букв, которые есть у Ивана. Во второй строке дано слово, которое придумал Иван. Строки содержат только строчные латинские буквы и не превышают 1000 символов.
Формат выходных данных
Выведите одно число – ответ на задачу.
2. В новогоднюю ночь каждому хочется получить подарок от Деда Мороза. И Деду Морозу надо приготовить N подарков. Он позвал на сказочных героев. Три гномика Деду Морозу упаковывать подарки. Первый гномик успевает упаковать один подарок за a минут, второй – за b минут, третий – за c минут. Дед Мороз очень обеспокоен, успеют ли они упаковать все подарки ему определить, за какое минимальное время в минутах все подарки будут упакованы.
Формат входных данных
В первой строке вводится целое число N (0  N  100000)
Во второй строке водятся 3 целых числа a, b, c (1  a, b, c  100).
Формат выходных данных
Одно число – ответ на задачу.
3. В магазине канцелярских товаров набор из трех ручек красного, черного и синего цвета стоят A тенге. Такие же ручки в комплектах: красной и черной стоят B тенге, красной и синей – C тенге, черной и синей – D тенге. Если покупать каждую ручку по отдельности, то за красную надо заплатить E тенге, за черную – F тенге, а за синюю – G тенге. Арлан хочет купить не менее X красных, Y черных и Z синих ручек. Определите минимальную стоимость покупки.
Формат входных данных
Вводятся 10 целых чисел (0  A, B, C, D, E, F, G  100, 0  X, Y, Z  20).
Формат выходных данных
Одно число – минимальная стоимость покупки.
4. Координаты шахматной доски пронумерованы слева направо и снизу вверх числами от 1 до 8. Даны координаты Ферзя (номер строки и номер столбца). Ферзь может ходить на любое число полей по вертикали, горизонтали или диагонали. Определите число клеток, в которых ферзь не может атаковать.
Формат входных данных
Вводятся 2 целых числа n, m(1n, m8), разделенных пробелом.
Формат выходных данных
Вывести одно число – ответ на задачу.
5. В школе для одаренных детей занятия начинаются в 8:00. Всего в день может быть 9 уроков. Продолжительность урока – 40 минут. После 1-го, 7-го, 8-го уроков перемена длится 5 минут, после 2-го и 4-го уроков –10 минут, после 3-го и 5-го уроков – 15 минут. После 6-го урока перемена 40 минут. По указанному времени определите,какой урок сейчас идет или идет перемена.
Формат входных данных
Вводятся 2 целых числа h (часы), m (минуты) (8  h  15, 0  m  59), разделенные пробелом.
Формат выходных данных
Если идет урок, то вывести номер урока, если идет перемена – вывести 0

Показать ответ
Ответ:
dariadarina1
dariadarina1
29.11.2021 05:39
1.
0,5 Кбайт = 0,5*1024 байт = 512*8 бит
512*8/128 = 32

2.
Память для одного символа = log(2)64=6 бит
Объем текста = 10*32*64*6 бит = 10*32*64*6/8 байт =
10*4*64*6/1024 Кбайт = 15 Кбайт

3.
3 Кбайт = 3*1024 байт = 3*1024*8 бит
Память для одного символа = 3*1024*8/6144 = 4 бита
Количество символов в алфавите = 2^4 = 16

4.
Память для одного символа = log(2)128=7 бит
Объем сообщения = 10*7 = 70 бит

8.
a) 3 Кбайт=3*1024 Байт = 3072 бАЙТ
b) 2 Мбайт=2*1024 Кбайт = 2*1024*1024 байт = 2*1024*1024*8 бит = 16777216 бит
c) 4,5 Гигабайт=4,5*1024 Мбайт = 4,5*1024*1024 Кбайт = 4718592 Кбайт
0,0(0 оценок)
Ответ:
01061969
01061969
22.01.2023 13:49
Задача №1
var a:array[1..4, 1..5] of integer; 
i,j,k:integer; 
begin 
writeln('Заполните матрицу'); 
for i:=1 to 4 do 
for j:=1 to 5 do begin 
read(a[i,j]); 
if (a[i,j] mod 3=0) and (a[i,j]>20) then k:=k+a[i,j]; 
end; 
writeln('Сумма элементов кратных 3-м и > 20 = ',k); 
end.

Задача №2
var a:array[1..5, 1..5] of integer; 
i,j,k:integer; 
begin 
writeln('Заполните матрицу'); 
for i:=1 to 5 do 
for j:=1 to 5 do begin 
read(a[i,j]); 
if i=j then k:=k+a[i,j]; 
end; 
writeln('Сумма элементов главной диагонали = ',k); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота