В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
koteleva
koteleva
31.12.2020 00:24 •  Информатика

решить задачу на C++ или Python: На острове расположены несколько государств, изолированных друг от друга. У программиста Васи есть данные обо всех дорогах острова, заданные в виде весовой матрицы соответствующего графа, узлы которого – города, а веса рёбер – расстояния между ними. Напишите программу, которая определяет, сколько государств находится на острове.

Показать ответ
Ответ:
мико141
мико141
07.07.2021 09:18

Сделал подробно. Двумя решениями. Через оператора if и else (Вам нужен только if, else для ознакомления)

--

IF

--

2)

Program ypriz;

var a,b,cc: real;

BEGIN

a:=2;

b:=-3;

if  a+b > 0 then

begin

 a:=10*a;

 b:=10*b

end

else

c:=a;

 a:=a+b;

 b:=c*b;

Writeln('Значение a, b: ',a);

END.

3)

Program asoft;

var a,b,c: real;

BEGIN

a:=2;

b:=-3;

if  a+b > 0 then

 a:=10*a;

 b:=10*b;

if a+b < 0 then

 c:=a;

 a:=a+b;

 b:=c*b;

writeln ('Значение a, b:',a,' ',b);

END.

--

ELSE

--

2)

Program ypriz;

var x,y,z: real;

BEGIN

z:=5;

if  z < 5 then

 y:=z+10;

if z > 5 then

 y:=z-10;

Writeln('Значение y: ',y);

END.

или

Program ypriz;

var x,y,z: real;

BEGIN

z:=5;

if  z < 5 then

 y:=z+10

else

 y:=z-10;

Writeln('Значение y: ',y);

END.

3)

Program asoft;

var a,b,c: real;

BEGIN

a:=2;

b:=-3;

if  a+b > 0 then

begin

 a:=10*a;

 b:=10*b

end

else

c:=a;

 a:=a+b;

 b:=c*b;

writeln ('Значение a, b:',a,' ',b);

END.

0,0(0 оценок)
Ответ:
ivanchistyakov
ivanchistyakov
11.05.2023 07:51

Программа-термин, в переводе означающий «предписание», то есть заданную последовательность действий.

Дизайн-деятельность по проектированию эстетических свойств промышленных изделий.

Проект-временно́е предприятие, направленное на создание уникального продукта, услуги или результата.

Меню-перечень блюд и напитков, подаваемых в кафе, ресторане или баре.

Качество – то, что характеризует природу вещи, ее принадлежность к определенному классу предметов.

Диалог- литературная или театральная форма устного или письменного обмена высказываниями (репликами, вопросами и ответами) между двумя и более людьми, также бывает письменный.

Интерфейс-граница между двумя функциональными объектами.

Звук-физическое явление, представляющее собой распространение в виде упругих волн механических колебаний в твёрдой, жидкой или газообразной среде.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота