В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Sveta1100
Sveta1100
18.10.2020 14:31 •  Информатика

решить задачу на паскаль Дан одномерный массив из 25 элиментов. элементы стоящие на четных местах равны 1/i на не четных местах равны 2/i. Написать программу и вывести полученый массив на экран.

Показать ответ
Ответ:
Айгульнафис
Айгульнафис
05.03.2020 03:55
// PascalABC.NET 3.2, сборка 1427 от 24.04.2017
// Внимание! Если программа не работает, обновите версию!

function Pow(x,y:BigInteger):BigInteger;
begin
  Result:=x;
  for var i:=int64(2) to int64(y) do Result*=x
end;

begin
  var x,y:integer;
  Write('Введите натуральные х и у: '); Read(x,y);
  if (x<=0) or (y<=0) then begin
    Writeln('Неверный ввод'); Exit
    end;
  if x=1 then Writeln('Результат: ',y+1)
  else begin
    var x1:=Range(2,x).Aggregate(BigInteger(1),(a,b)->a*b);
    Writeln('Результат ',Pow(x,y)+Pow(y,x1))
    end
end.

Пример
Введите натуральные х и у: 5 8
Результат 2348542582773833227889480596789337027375682548908319870707290971532209025114608443463698998384768703032325601
0,0(0 оценок)
Ответ:
yokofoku
yokofoku
07.10.2021 15:31
Граф - множество вершин и ребер, соединяющих эти вершины.
Он несет информацию об элементах системы и связи между ними.
Элементы системы изображаются как вершины или узлы графа.
Отношения между ними изображаются как ребра или дуги графа.
Деревом называют ациклический (то есть между любыми вершинами есть только один путь), связный (то есть от любой вершины графа можно добраться в другую) граф.
Корень дерева - это вершина с нулевой степенью захода (то есть в нее не ведут другие ребра). Для неориентированного графа это просто выбранная нами вершина.
Ветви - это ребра дерева.
Листья дерева - это вершины с нулевой степенью исхода (то есть из них не выходят ребра), т.е. не имеющих поддеревьев.
Надеюсь объяснил доступно.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота