В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dimas1410
dimas1410
21.04.2020 08:54 •  Информатика

решить задачу на ПИТОНЕ! Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 2. Кол. Чисел не превышает 1000. Программа должна вывести одно число - максимальное число, оканчивающееся на 2

Показать ответ
Ответ:
vika1722
vika1722
15.06.2021 16:38

import random

mass = []

masscomp = []

max = 0

for i in range(0, 1000):

   mass.append(random.randint(0, 1000000))

   masscomp = [int(x) for x in str(mass[i])]

   if (mass[i] > max and masscomp[len(masscomp) - 1] == 2):

       max = mass[i]

print(max)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота