В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Решить задачу на питоне Шли как-то два математика по лесу и собирали ягоды. Час шли, два шли, а потом вдруг остановились и решили ягодами помериться. Достали они весы (какой же математик пойдет в лес без весов?) и взвесили свои корзины с собранным урожаем, а потом записали полученные числа a 1 и b 1 на листочек. После этого второй математик пересыпал все ягоды в корзину к первому (полностью опустошив свою корзину), и они снова взвесили свои корзины, получив числа a 2 и b 2 соответственно. Наконец, первый математик пересыпал все ягоды в корзину ко второму (полностью опустошив свою корзину); после взвешивания они получили числа a 3 и b 3 соответственно. Этих данных оказалось достаточно для определения победителя, и довольные математики пошли дальше. Вам же предстоит вычислить массу ягод в корзине каждого из математиков до совершения всех пересыпаний. Формат ввода Входные данные состоят из трёх строк. В i -й строке ( 1 ≤ i ≤ 3 ) записаны целые числа a i и b i ( 0 ≤ a i , b i ≤ 10000 ) . Формат вывода В единственной строке выведите пару целых чисел через пробел - сколько ягод собрали, соответственно, первый и второй математик.

Показать ответ
Ответ:
Shaxnoza2509
Shaxnoza2509
21.02.2021 16:52

ответ:

брат такой ответ дал незнаю нащет правельно с и но может правельно)

c++выделить код

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

#include

#include

#include

#include

#include

using namespace std;

void main()

{

setlocale(0, "");

srand(time(null));

int a[10] = {};

int b[5] = {};

int c[5] = {};

for (int i = 0, q = 0; i < 10; i++)

{

a[i] = rand() % (20 - (-20) + 1) + (-20);

cout < < a[i] < < endl;

if (a[i] % 2 == 0)

{

cout < < "" < < endl;

b[q] = a[i];

0,0(0 оценок)
Ответ:
sitkavetskiy
sitkavetskiy
01.09.2021 17:22

ответ:

uses crt;

 

var s,sf,sl: string;

    i,l: integer;

 

begin

writeln('введите слова: ');

readln(s);

if s[1]=' ' then       //проверяем, чтобы не было пробелов в начале строки

  repeat

  delete(s,1,1);       //удаляем пробелы в начале строки, если они есть

  until s[1]< > ' ';

l: =length(s);

if s[l]=' ' then       //проверяем, чтобы не было пробелов в конце строки

  repeat

  delete(s,l,1);       //удаляем пробелы в начале строки, если они есть

  dec(l);

  until s[l]< > ' ';

i: =1;

sf: =''; sl: ='';         //изначально переменные для первого и последнего слова пусты

while s[i]< > ' ' do       //начинаем с первого символа и прекрепляем к первому слову

      begin

      sf: =sf+s[i];       //по одному символу до тех пор, пока не дойдем до пробела

      inc(i);           //увеличиваем счетчик символов на 1

      end;

i: =l;

while s[i]< > ' ' do     //начинаем с последнего символа и прекрепляем ко второму слову (спереди, то есмть по сути перед словом =))

      begin

      sl: =s[i]+sl;     //по одному символу до тех пор, пока не дойдем до пробела

      dec(i);         //уменьшаем счетчик символов на 1

      end;

writeln(sf,' ',sl);   //вывод

readln;

end.

объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота