решить задачу. С++ На сигнал воздействует N аддитивных помех. Напишите программу, вычисляющую мгновенное значение сигнала S (задается пользователем в виде числа) на выходе канала связи. Используйте рекурсивный алгоритм.
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017 // Внимание! Если программа не работает, обновите версию!
begin Writeln('*** Дополните до ста! ***'); Writeln('Вам будут предлагаться числа, которые нужно дополнять до 100'); Writeln('Для завершения работы введите 0'); var a,q,k,m:integer; k:=0; m:=0; repeat q:=Random(1,99); Print(q); Read(a); if a=0 then break; if a=100-q then begin m+=1; Writeln('Это правильный ответ') end else Writeln('Это неправильный ответ, ',100-q); k+=1; until false; Writeln('Задано вопросов- ',k,', верных ответов- ',m,' (',100*m/k:0:1,'%)') end.
Пример *** Дополните до ста! *** Вам будут предлагаться числа, которые нужно дополнять до 100 Для завершения работы введите 0 80 20 Это правильный ответ 5 95 Это правильный ответ 51 49 Это правильный ответ 4 95 Это неправильный ответ, 96 90 10 Это правильный ответ 11 0 Задано вопросов- 5, верных ответов- 4 (80.0%)
Program a1; // a1 - название твоей проги, с задают название программы. var a,b,c, s : integer; // a, b, c, s - переменные. var — ключевое слово, после этого слова объявляют переменные. begin // begin и end — это как скобки, в которых ты решаешь выражение readln(a); readln(b); readln(c); // readln() — оператор, с которого можно отправлять данные в компьютер. Есть и такая fорма записи. read(). Отличие read от readln в том, если использует второй вариант readln(), то каретка( _) переносится на новую строку. s := b*2-4*a*a; // присваиваем значения переменных в переменную s. if (s > 0) then // конструкция if else позволяет проверять условия, если это равно или не равно, то делай компьютер другое... writeln(' Число положительное'); else if (s < 0) then writeln(' Число отрицательное'); // writeln() выводит инfу на экран. end.
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Дополните до ста! ***');
Writeln('Вам будут предлагаться числа, которые нужно дополнять до 100');
Writeln('Для завершения работы введите 0');
var a,q,k,m:integer;
k:=0; m:=0;
repeat
q:=Random(1,99);
Print(q); Read(a);
if a=0 then break;
if a=100-q then begin
m+=1;
Writeln('Это правильный ответ')
end
else Writeln('Это неправильный ответ, ',100-q);
k+=1;
until false;
Writeln('Задано вопросов- ',k,', верных ответов- ',m,' (',100*m/k:0:1,'%)')
end.
Пример
*** Дополните до ста! ***
Вам будут предлагаться числа, которые нужно дополнять до 100
Для завершения работы введите 0
80 20
Это правильный ответ
5 95
Это правильный ответ
51 49
Это правильный ответ
4 95
Это неправильный ответ, 96
90 10
Это правильный ответ
11 0
Задано вопросов- 5, верных ответов- 4 (80.0%)
var a,b,c, s : integer; // a, b, c, s - переменные. var — ключевое слово, после этого слова объявляют переменные.
begin // begin и end — это как скобки, в которых ты решаешь выражение
readln(a);
readln(b);
readln(c);
// readln() — оператор, с которого можно отправлять данные в компьютер. Есть и такая fорма записи. read(). Отличие read от readln в том, если использует второй вариант readln(), то каретка( _) переносится на новую строку.
s := b*2-4*a*a; // присваиваем значения переменных в переменную s.
if (s > 0) then // конструкция if else позволяет проверять условия, если это равно или не равно, то делай компьютер другое...
writeln(' Число положительное');
else if (s < 0) then
writeln(' Число отрицательное');
// writeln() выводит инfу на экран.
end.