В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ada9797
ada9797
08.12.2021 10:02 •  Информатика

решить задание по информатике, под номером 4 и 7 и напишите программу на паскале

Показать ответ
Ответ:
polinakarpova4
polinakarpova4
04.08.2020 01:18

Объяснение:

Вредная информация-Реклама игр для детей старше 18 лет , реклама неприличных книг, разные посты в соц сетях которые являются пропагандой чего то плохого , азартные игры, помимо опасностей человеческих, есть еще опасности чисто технические. Заблудившись в сети очень легко заразить компьютер вредоносными программами. Кража паролей и прочей конфиденциальной информации, спам от вашего имени, хулиганство, вымогательство, угрозы

нежелательная информация. В интернете кроме орнографических сайтов существуют ресурсы, на которых в подробностях рассказывается о создании взрывных или поджигающих устройств, идеализируется такое понятие, как суіцид, употребление алкоголя, табака и запрещенных нарк@тических препаратов.

0,0(0 оценок)
Ответ:
13913
13913
22.03.2023 18:58
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

type
  CheckBalls=class
 
  private
   
    ad:array of real; // диаметры шариков
    ap:array of real; // веса шариков
    etD:=24.0; // эталонный диаметр
    derD:=2.0; // эталонное предельное отклонение
    etP:=74.0; // эталонный вес
    derP:=3.0; // эталонное предельное отклонение
   
    procedure CheckBall(m:integer);
    // проверка шарика с указанным номером
    begin
      Write('Шарик № ',m,': диаметр - ');
      if Abs(aD[m-1]-etD)<=derD then Write('норма')
      else Write('брак');
      Write(', вес - ');
      if Abs(aP[m-1]-etP)<=derP then Writeln('норма')
      else Writeln('брак')
    end;
  
 
  public
 
    constructor(ma,mp:array of real);
    begin
      ad:=Copy(ma);
      ap:=Copy(mp);
    end;
   
    procedure CheckAllBalls;
    begin
      for var i:=1 to ad.Length do CheckBall(i)
    end;
 
end;

begin
  var n:=120; // число шариков
  var a:=SeqRandom(n,200,280).Select(t->t/10).ToArray;
  var b:=SeqRandom(n,700,800).Select(t->t/10).ToArray;
  Writeln('Параметры шариков (диаметр,вес):');
  a.Zip(b,(p,q)->(p,q)).Println;
  Writeln('Результаты контроля:');
  var oL:=new CheckBalls(a,b);
  oL.CheckAllBalls
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота