В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
stasleraz
stasleraz
02.04.2021 18:12 •  Информатика

Решите : 1) введите элементы массива а[1..10] с клавиатуры и вычислите количество элементов с четными положительными значениями. 2) составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 20 и выводит на экран элементы, значения которых больше 5 и меньше 15. заранее за решение.

Показать ответ
Ответ:
satursacha
satursacha
24.06.2020 16:27
1)
program test;
uses crt;
var
  arr:array[1..10] of integer;
  i,cou:integer;
begin
clrscr;
  for i:=1 to 10 do
  begin
    write('Itput arr[',i,'] ');readln(arr[i]);
    if (arr[i]>0) and (arr[i] mod 2 = 0) then cou:=cou+1;
  end;
  writeln(cou);
end.

2)Тут вообще можно 1 циклом обойтись, но так не надо заворачиваться с перетаскиванием курсора.
program test;
uses crt;
var
  arr:array[1..10] of integer;
  i:integer;
begin
  randomize;
  clrscr;
  for i:=1 to 10 do
    begin
      arr[i]:=random(20)+1;
      write(arr[i],' ');
    end;
  writeln;
  for i:=1 to 10 do
    if (arr[i]>5) and (arr[i]<15) then write(arr[i],' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота