В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
150819761
150819761
31.03.2023 22:12 •  Информатика

Решите 2,3 и 4. 2. Написать программу определения большего из двух значение, если одно
указано в метрах, а второе в сантиметрах
3. Написать программу определения является ли введенное натуральное
число однозначным
4. Написать программу вычисления модуля разности двух чисел


Решите 2,3 и 4. 2. Написать программу определения большего из двух значение, если одно указано в мет

Показать ответ
Ответ:
кукушка139
кукушка139
11.05.2020 22:15

Монито́р — устройство, предназначенное для воспроизведения видеосигнала и визуального отображения информации, полученной от компьютера. Принципиальное отличие от телевизора заключается в отсутствии встроенного тюнера, предназначенного для приёма высокочастотных сигналов эфирного (наземного) телевещания. Кроме того, в большинстве мониторов отсутствует звуковоспроизводящий тракт и громкоговорители.

Современный монитор состоит из экрана (дисплея), блока питания, плат управления и корпуса. Информация для отображения на мониторе поступает с электронного устройства, формирующего видеосигнал (в компьютере — видеокарта или графическое ядро процессора).

0,0(0 оценок)
Ответ:
ihorrubalko
ihorrubalko
16.10.2020 17:20

Код, приведенный ниже, работает не только со словами, но и со строками.

Например, "На в лоб, Болван" определяется как полиндром.


using System;

using System.Linq;

using System.Text.RegularExpressions;


namespace PolyndromeFinder

{

   class Program

   {

//

// [START] Тот самый участок кода

//

       static bool IsPolyndrome(string victim)

       {

           victim = victim // Нормализуем строку

               .Replace(" ", "")

               .Replace(",", "")

               .Replace(".", "")

               .Replace("?", "")

               .Replace("!", "")

               .ToLower();

           var check = new Regex(victim); // Создаём на её основе регулярное выражение

           return check.IsMatch(new string(victim.Reverse().ToArray())); // Переворачиваем строку и сверяем с регуляркой

       }

//

// [END] Тот самый участок кода

//


       static void Main(string[] args)

       {

           bool answer;

           while (true)

           {

               Console.Write("Введите строку: ");

               string superPositionPolyndrome = Console.ReadLine();

               Console.WriteLine("Это{0} полиндром!\n", (answer = IsPolyndrome(superPositionPolyndrome))? "": " НЕ");

           }

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота