В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
katcornewa
katcornewa
17.01.2020 20:58 •  Информатика

Решите 4 задачи на питон о
Условие

1)Необходимо найти произведение всех целых чисел от a
до b

.
Формат входных данных
Вводятся два целых числа a
и b (−231≤a≤b≤231−1)
.
Формат выходных данных
Требуется вывести одно число — искомое произведение. Гарантируется, что ответ не превышает по модулю 230
.
входные данные
1 5

5 8
выходные данные
120

1680

2)Условие

Даны числа A
и B. Необходимо посчитать сумму всех целых чисел от A до B

включительно.
Формат входных данных
С клавиатуры вводятся через пробел два целых числа A
и B, (−1000≤A≤B≤1000)
.
Формат выходных данных
Необходимо вывести единственное число — искомую сумму.

входные данные

1 10

выходные данные

55
3)Вывести: n+(n−1)+(n−2)+(n−3)+...+3+2+1

.
Формат входных данных

Вводится целое положительное число n
(1≤n≤213

).
Формат выходных данных

Вывести сумму, сформированную по принципу, указанному выше.

7
3

выходные данные
28

6
4)Условие

Дима поспорил со своим учителем математики: если Дима сможет сходу назвать последовательность чисел, сформированную по принципу:

1 * 2

2 * 2

3 * 2

и т.д.

То Дима получит 5 в четверти! Бинго!

Учитель называет Диме одно целое число N, а ученик называет все числа последовательности от 1*2 до N*2.

Напишите программу, которая печатает на экран в столбик все числа последовательности.
Формат входных данных

Целое число 1≤ N ≤ 1000
Формат выходных данных

Последовательность в столбик
входные данные

5

выходные данные

2
4
6
8
10

Показать ответ
Ответ:
UtkinaVioletta
UtkinaVioletta
29.10.2020 20:19

#include <iostream>

using namespace std;

int main()

{

   int y, x;

   cin >> x >> y;

   int a[8][8];

   for (int i = 0; i < 8; ++i)

       for (int j = 0; j < 8; ++j)

         a[i][j] =  0;

   y--;

   x--;

   

   int px = x, py = y;

   while (px >= 0 && py >= 0){

       a[px][py] = 2;

       px--;

       py--;

     

   }

   

   px = x, py = y;

   while (px >= 0 && py < 8){

       a[px][py] = 2;

       px--;

       py++;

   }

   

   px = x, py = y;

   while (px < 8 && py < 8){

       a[px][py] = 2;

       px++;

       py++;

   }

   

   px = x, py = y;

   while (px < 8 && py >= 0){

       a[px][py] = 2;

       px++;

       py--;

   }

   

   px = 0;

   while (px < 8){

       a[px][y] = 2;

       px++;

   }

   

   py = 0;

   while (py < 8){

       a[x][py] = 2;

       py++;

   }

   

   a[x][y] = 1;

   for (int i = 0; i < 8; ++i){

       for (int j = 0; j < 8; ++j){

           if(a[i][j] == 0) cout << "." << " ";

           else if(a[i][j] == 1) cout << "Q" << " ";

           else cout << "*" << " ";

       }

       cout << endl;

   }

   return 0;

}

Объяснение:

вроде все просто, не знаю, что объяснять. скорее всего, есть возможность сделать это гораздо более оптимизировано, но мне было лень думать, так что сделал тупым и неоптимизированным методом, состоящем из кучи циклов while.

P. s. Если , дайте лучший ответ и жмякните на " " . Это мотивирует давать ответы дальше.

0,0(0 оценок)
Ответ:
justlikekatya
justlikekatya
20.06.2021 13:11
)

Если длина массива d(количество делителей числа d) > 17:

 if (len(d) > 17):

То выполняем следующие действия:

- количество подходящих под условии чисел (count) увеличиваем на 1

   count += 1  

- сравниваем минимальное подходящее число min и текущее now_el (и при необходимости присваиваем новое значение  (min=now_el))

   if(min > now_el):  

     min = now_el

Увеличиваем значение переменной текущего элемента (now_el) на 1:

 now_el+=1  

Выводим полученный результат:

print('ответ:')

print(count, min)


ПОЧИНИТЬ код! После запуска ничего не происходит. ответ должен быть 706630008. Сделайте все понятно,
ПОЧИНИТЬ код! После запуска ничего не происходит. ответ должен быть 706630008. Сделайте все понятно,
ПОЧИНИТЬ код! После запуска ничего не происходит. ответ должен быть 706630008. Сделайте все понятно,
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота