В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Решите:
Дано целое трёхзначное число х. Составьте программу вычисления суммы и произведения цифр трёхзначного числа х. Значение х ввести с клавиатуры.
Язык программирования Паскаль

Показать ответ
Ответ:
zombdanidani
zombdanidani
01.02.2021 01:00

Прости что не текстом :(


Решите: Дано целое трёхзначное число х. Составьте программу вычисления суммы и произведения цифр трё
0,0(0 оценок)
Ответ:
mongoliya1
mongoliya1
01.02.2021 01:00

var

s,pr,x : integer;

begin

readln(x);

x := abs(x);

s:= 0;

pr:= 1;

while x > 0 do

begin

s := s + x mod 10;

pr := pr * x mod 10;

x:= x div 10;

end;

writeln('S = ',s);

writeln('PR = ',pr);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота