В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Решите эти на питоне
№ 4.2.7

дана непустая последовательность целых чисел, оканчивающаяся нулем. найти сумму и количество введенных чисел.

№ 4.2.9

дано вещественное число a. найдите наименьшее натуральное n, для которого верно

1+1/2+1/3++1/n> a

№ 4.2.11

вывести в строку 10 первых натуральных чисел, оканчивающихся на цифру k, кратных числу s и находящихся в интервале, левая граница которого равна start.

Показать ответ
Ответ:
SVT38
SVT38
09.10.2020 06:18

# 1

x, n, summ = 1, -1, -1

while x != 0:

   summ += x

   n += 1

   x = int(input())

print(summ, n)

# 2

a = float(input())

summ, n = 0.0, 0

while summ <= a:

   n += 1

   summ += 1/n

print(n, summ)

# 3

s, k, start = (int(input()) for i in range(3))

n = 0

while n < 10:

   if start % 10 == k and start % s == 0:

       print(start, end=' ')

       n += 1

   start = start + s if n != 0 else start + 1

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота