В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Maximus20000
Maximus20000
22.07.2020 14:21 •  Информатика

Решите хотя бы пару из них. 1. дано целое число n. написать программу, заменяющую его нулем, если число меньше нуля, и увеличивающую его на 4, если число неотрицательное. 2. даны целые числа a и b. написать программу, которая выводит число 1, если числа равны, и число 0 в противном случае. 3. даны целые числа a, в и с. написать программу, подсчитывающую количество неотрицательных чисел среди данных. 4. даны целые числа a, в и с. написать программу, подсчитывающую сумму положительных чисел среди данных. 5. даны числа a, в и с. написать программу, выводящую их в убывающем порядке. 6. даны целое трехзначное число n и целое число k. написать программу, подсчитывающую сумму тех цифр числа n, которые больше k. 7. дано натуральное число n. написать программу, подсчитывающую сумму 1+2+3+…+n. 8. даны натуральные числа а и в (в 9. дано натуральное число n. написать программу, выводящую на экран последовательность натуральных чисел от n до 1. 10. дано натуральное число n. написать программу для вычисления суммы . 11. дано натуральное число n. написать программу для вычисления суммы . 12. дано натуральное число n (n< 10). написать программу, для вычисления суммы вида 0,1+0,2+0,3+… (n слагаемых). 13. дано натуральное число n. написать программу, выводящую на экран последовательность квадратов всех чисел от 1 до n. 14. дано натуральное число n. написать программу, выводящую последовательность первых n нечетных чисел. 15. дано n натуральных чисел. написать программу, вычисляющую их среднее арифметическое. число n вводится перед всеми остальными. 16. дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). написать программу, которая подсчитывает количество чисел в последовательности. 17. дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). написать программу, которая подсчитывает количество четных чисел в последовательности (число 0 для вычисления результата считать не надо). 18. дана последовательность целых чисел, заканчивающаяся нулем и содержащая еще один нуль в произвольном месте. написать программу, которая подсчитывает количество чисел между нулями. 19. дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). написать программу, которая выводит последнее ненулевое число последовательности. 20. дано целое число n (> 0). если оно является степенью числа 3, то вывести true, если не является – вывести false. 21. дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). написать программу, находящую максимальное число последовательности. 22. написать программу, определяющую количество трехзначных натуральных чисел, сумма цифр которых равна заданному числу n (> 0). 23. дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). написать программу, выводящую все числа последовательности, кратные трем. 24. как и многие другие девочки, маша любит разные гадания. некоторое время назад маша узнала новый гадать на числах – для какого-нибудь интересующего ее натурального числа n надо посчитать сумму всех чисел, на которые n делится без остатка. маша не любит арифметику, и попросила вас написать программу, которая автоматизирует процесс гадания. ввод: натуральное число n (n ≤ 1000). вывод: сумма всех натуральных делителей числа n. 25. петя и катя – брат и сестра. петя – студент, а катя – школьница. петя кате по . он задумывает два натуральных числа x и y (x,y≤1000), а катя должна их отгадать. для этого петя делает две подсказки. он называет сумму этих чисел s и их произведение p. кате отгадать задуманные петей числа. ввод: два натуральных числа s и p, разделенные пробелом. вывод: два числа х и y, загаданные петей. числа следует вывести в порядке неубывания своих значений, разделенные пробелом. 26. даны два натуральных числа a и b. требуется найти их наибольший общий делитель (нод). ввод: натуральные числа a и b через пробел (a, b ≤ 109). вывод: нод чисел а и в.

Показать ответ
Ответ:
sashaiseneev
sashaiseneev
03.10.2020 00:17
Var
    N, s, i: Integer;
    s1: real;

begin
    readln(N); {общий ввод для всех задач}
    
    if N < 0 then
        writeln('Задача 1. N=', 0)
    else writeln('Задача 1. N=', N + 4);
    
    s := 0;
    for i := 1 to n do
        s := s + i;
    writeln('Задача 7. 1+2+3+…+N=', s);
    
    write('Задача 9. Последовательность от N до 1 = ');
    for i := n downto 1 do
        write(i, ' ');
    writeln();
    
    s1 := 0;
    for i := 1 to n do
        s1 := s1 + i / 10;
    writeln('Задача 12. 0,1+0,2+0,3+..+N/10=', s1);
    
    write('Задача 13. Последовательность квадратов от 1 до N = ');
    for i := 1 to n do
        write(i * i, ' ');
    writeln();
    
    write('Задача 14. Последовательность первых N нечетных чисел = ');
    for i := 1 to n do
        write(2 * i - 1, ' ');
    writeln();
    
    if N > 0 then
        writeln('Задача 20. N степень 3 = ', frac(ln(n) / ln(3)) = 0);
    
    s := 0;
    for i := 1 to n do
        if n mod i = 0 then
            s := s + i;
    writeln('Задача 24. Сумма всех натуральных делителей числа N (сключая 1 и N) = ', s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота