В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Решите на питоне:Остап Бендер, сын турецко-подданного, за свою жизнь переменил много занятий. Живость характера постоянно кидала его в разные концы страны и теперь привела в Старгород без носков, без ключа, без квартиры и без денег. Лежа в теплой до вонючести дворницкой, Остап Бендер отшлифовывал в мыслях возможные варианты своей карьеры.

Напишите программу, которая ему в этом, а именно из предложенных чисел выберет только те, что больше последнего среди всех введенных чисел и имеют с ним ту же чётность.

Формат ввода
Вводится строка целых чисел, записанных через пробел.

Формат вывода
Вывести числа, которые больше последнего и имеют с ним ту же чётность, без повторений, порядок вывода значения не имеет.

Показать ответ
Ответ:
Ka4erga3000
Ka4erga3000
28.10.2022 01:24
Шупашкар Чăваш Республикин тĕп хули. Шупашкарта пĕтĕмпе 460,2 пин çын (2002 çулхи халăх çыравĕ тăрăх) пурăнать. Шупашкар Чулхулапа Хусан хулисем хушшинче, Атăл юханшывăн сылтăм çыранĕнче вырнаçнă. Шупашкар виçĕ района пайланать: Калинин районĕ, Ленин районĕ, Мускав районĕ тата Атăл лешьенчи çĕр тытăмĕ. Шупашкартан инçех мар хула-спутникĕ Çĕнĕ Шупашкар вырнаçнă. Унта пĕтĕмпе 125 пин çын пурăнать. Шупашкар кунĕ: çурла уйăхĕн виççĕмĕш вырсарникунĕ. Шупашкар хулинчен аякрах мар Атăл тăрăх кайсан Çĕнĕ Шупашкар, Сĕнтĕрвăрри, Куславкка хулисем вырнаçнă.
0,0(0 оценок)
Ответ:
Ramiz2005
Ramiz2005
06.05.2020 03:15
#генерируем список из 2000 элементов
my_list = [(lambda x:(x*296+2410)%4096)(i) for i in range(2000)]

# начальное значение для временного минимума
min1_value = min2_value = 10000
min1_number = min2_number = 0

while my_list:
    x = my_list.pop()
    if x < min1_value:
        min2_value = min1_value
        min2_number = min1_number
        min1_value = x
        min1_number = 1
    elif x == min1_value:
        min1_number += 1
    elif x < min2_value:
        min2_value = x
        min2_number = 1
    elif x == min2_value:
        min2_number += 1
        
print(min2_number)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота