В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
schastlivayolg
schastlivayolg
23.07.2020 05:56 •  Информатика

Решите на python(алгоритм решения есть,осталось реализовать в коде) Андрей изучает социальные сети и пытается определить скрытые атрибуты пользователей по их друзьям. Поскольку Андрей - профессиональный программист, то он хочет протестировать свою программу прежде чем верить ее результатам. Но для этого требуется много разных графов, похожих на социальные сети. Андрей хочет получать графы с разным количеством пользователей (т. е. вершин графа) и разными отношениями дружбы (т. е. ребрами графа). Отношение дружбы ненаправленное. В графе не должно быть петель и кратных ребер. Андрей будет задавать желаемое количество вершин и желаемое среднее количество ребер, инцидентных вершине. Его устроит даже граф, если эти его характеристики будут отличаться от заданных, но не более чем на 20%.

Ваша программа получает на вход 2 целых положительных числа - N - количество вершин и K - среднее количество ребер у вершины (1≤ N ≤ 200, 0 ≤ K ≤ N - 1)

Программа печатает граф описанного вида. В первой строке печатается количество вершин графа. Начиная со следующей строки, печатается матрица смежности графа по строкам. Вершины нумеруются последовательно, начиная с 0. Элемент матрицы смежности равен 1, если соответствующее ребро входит в граф, и 0, иначе. Элементы разделяются пробельными символами. Элементы главной диагонал матрицы смежности должны равняться 0. Если графа описанного вида не существует, программа ничего не печатает.

Рассмотрим неориентированный граф с количеством вершин M и количеством ребер L. Такой граф точно существует, если 0<=L<=M(M-1)/2. Итого для целых чисел M и L должно выполняться
0<=L<=M(M-1)/2
0.8K<=L<=1.2K
0.8N<=M<=1.2N
M и L можно найти простым перебором.
Если найдены целые числа M и L, удовлетворяющие этим условиям, то строим граф с M вершинами и L ребрами.​

Показать ответ
Ответ:
20070706
20070706
09.03.2023 07:33

Объяснение:

1) Как при решении задач обозначают информационный объем сообщения?:

1)I

2) К какому виду программного обеспечения относят текстовые и графические редакторы, редакторы презентаций, мультимедийные проигрователи. (в ответе укажите только одно слово)

Прикладное

3) Как называется поименованная область памяти, хранящая в себе любые данные?( в ответе запишите слово)

Файл

4) Пользователь работал с каталогом C:\Документы\Договоры\Продажа. Сначала он поднялся на один уровень вверх, затем спустился в каталог затем спустился в каталог Покупка. Укажите полный путь каталога, в котором оказался пользователь:

2) C:/Документы/Договоры Покупка

5) В некотором каталоге хранился файл с именем ex.pas. После того как в этом каталоге создали подкаталог Pascal и переместили в него файл ex.pas, полное имя файла стало C:\Olimp\Ivanov\Pascal\ex.pas. Каким было полное имя этого файла до перемещения?:

2) C:/Olimp/Ivanov/ex.pas

6) Валя шифрует русские слова, записывая вместо каждой буквы её код (см. таблицу). Даны кодовые цепочки:

232323 654313 210201 203033

Найдите среди них ту, которая имеет только одну расшифровку, и запишите в ответе расшифрованное слово.

ответ - Бита

7) Агент 007, передавая важные сведения своему напарнику, закодировал сообщение придуманным шифром. В сообщении присутствуют только буквы из приведённого фрагмента кодовой таблицы. Определите, какое сообщение закодировано в строчке

€ ? ? € ? ? €

М - € ? ; Ы - ? ? € ; Ш - ? ? ; К - ? € ; А - ? € ?

€ ? ? € ? ? € = МАК.

8) К графическим форматам растровой графики относят?:

1) bmp

4) TIFF

9) Как называется вид компьютерной графики, основанная на математических вычислениях?:

3) фрактальная

10) Процесс оформления текста в информатике называют форматированием. К чему оно может быть применено?:

5) все варианты верны

11) Согласитесь или не согласитесь с утверждениями:

1) Отличием текстового редактора от текстового процессора является то, что функционал текстового редактора шире. Нет

2) Список - демент визуализации информации демент? Не понятно что это (

3) Gimp- растровый графический редактор ДА

4) Delete удаляет символ справа от курсора Да

12) Как называется минимальный объект компьютерной презентации?:

2) слайд

13) Сколько Кбайт содержится в 24576 битах? ( в ответе укажите число, единицы измерения писать не нужно)

ответ - 3

14) Чему равна разрядность двоичного кода , если количество кодовых комбинаций равно 512?

ответ - 9

15) Укажите информационные процессы:

1) сбор

3) хранение

4) обработка

5) передача

0,0(0 оценок)
Ответ:
соня3161
соня3161
27.04.2023 18:24

Т.к. требуется использовать цикл until, то значит требуется код на языке Паскаль.

1) цикл for

program p_for

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  p := 1;//начальное значение

  for i := 1 to n do  

     p := p * i;

  writeln(p);

end.  

2) цикл while

program p_while

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  while i <= n do  

  begin

     p := p * i;

     i := i + 1;

 end;

 writeln(p);

end.  

3) цикл until

program p_until

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  repeat

     p := p * i;

     i := i + 1;

  until i > n;

  writeln(p);

end.  

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота