Решите на языке pascal
собрались как-то олигархи и стали хвастаться – у кого денег больше. первый олигарх говорит – у меня одних долларов 100 миллиардов, а ещё евров 50 миллиардов, и рублей полно. второй ему отвечает – подумаешь, кому сейчас твои доллары нужны, у меня вот британских фунтов стерлингов 76 миллиардов с копейками, да тугрики монгольские, да динары алжирские тут все олигархи как закричат, как ногами затопают… и подрались, синяков друг другу наставили, а одному олигарху зуб выбили. а всё потому, что олигархи были глупые – надо было не кричать, и не драться, а спокойно пересчитать все их сбережения, непосильным трудом нажитые, в родные рубли, тогда сразу бы ясно стало, кто из них самый богатый.
напишите программу, которая определяет самого богатого из олигархов.
вход
в первой строке входного файла записаны натуральные числа n – количество олигархов и m — количество разных валют, в которых они хранят свои сбережения (2 < = n < = 1000, 1 < = m < = 100). во второй строке записано m вещественных чисел – курсы валют по отношению к рублю. в остальных n строках записано по m целых чисел в каждой. j-е число в i-ой из этих строк равно количеству миллиардов в j-ой валюте у i-го олигарха.
выход
запишите в выходной файл номер самого богатого олигарха. если таких олигархов несколько, запишите наименьший из номеров.
идея компьютера была предложена чарльзом бэбиджем (charles babage) в середине девятнадцатого века. его механическая «аналитическая машина» так и не смогла по-настоящему заработать, потому что технологии того времени не удовлетворяли требованиям, необходимым для изготовления нужных деталей точной механики. конечно, никакой речи об операционной системедля этого «компьютера» не шло. настоящее рождение цифровых вычислительных машин произошло вскоре после окончания второй мировой войны. в середине 40-х были созданы первые ламповые вычислительные устройства. в то время одна и та же группа людей участвовала и в проектировании, и в эксплуатации, и в программировании вычислительной машины. это была скорее научно-исследовательская работа в области вычислительной техники, а не использование компьютеров в качестве инструмента решения каких-либо практических из других прикладных областей. программирование осуществлялось исключительно на машинном языке. не было никакогосистемного программного обеспечения, кроме библиотек и служебных подпрограмм, которые программист мог использовать для того, чтобы не писать каждый раз коды, вычисляющие значение какой-либо функции или стандартным устройством ввода-вывода.операционные системывсе еще не появились, все организации вычислительного процесса решались вручную каждым программистом с пульта , который представлял собой примитивное устройство ввода-вывода, состоящее из кнопок, переключателей и индикаторов. с середины 50-х годов начался новый период в развитии вычислительной техники, связанный с появлением новой технической базы. выросло , увеличились объемыоперативнойи внешней памяти. компьютеры стали более надежными, теперь они могли непрерывно работать настолько долго, чтобы на них можно было возложить выполнение действительно практически важных . но выполнение каждой программы включало в себя большое количество работ (загрузка, запуск, получение результирующей программы в машинных кодах и т. поэтому для организации эффективного совместного использования были введены должности операторов, профессионально выполнявших работу по организации вычислительного процесса для всех пользователей этого центра.
но как бы быстро и надежно ни работали операторы, они никак не могли состязаться в производительности с работой устройств компьютера. а поскольку процессорпредставлял собой весьма дорогое устройство, то низкая эффективность его использования означала низкую эффективность использования компьютера в целом. для решения этой проблемы и были разработаны первые системыпакетной обработки, которые автоматизировали всю последовательность действий оператора по организации вычислительного процесса. ранние системыпакетной обработкиявились прообразом современныхоперационных систем, они стали первыми системными программами, предназначенными не для обработки данных, а для вычислительным процессом.
в ходе реализации систем пакетной обработкибыл разработан формализованный язык , с которого программист сообщал системе и оператору, какие действия и в какой последовательности он хочет выполнить на вычислительной машине.
ранние системы пакетной обработки значительно сократили затраты времени на действия по организации вычислительного процесса, а значит, был сделан еще один шаг по повышению эффективности использования компьютеров. однако при этом программисты-пользователи лишились непосредственного доступа к компьютеру, что снижало эффективность их работы — внесение любого исправления требовало значительно больше времени, чем при интерактивной работе за пультом машины.
ЯП: С++
#include <iostream>
int main() {
const int N = 5;
int arr[N][N] = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25}; // создаем и заполняем двумерный массив 5x5
for (int i = 0; i < N; i++) // выводим на экран 2-мерный массив;
{
for (int j = 0; j < N; j++)
{
std::cout << arr[i][j] << "\t";
}
std::cout << std::endl;
}
std::cout << "Result #1: ";
for (int i = 0; i < N; i++) // вывод в консоль главной диагонали
{
std::cout << arr[i][i] << "\t";
}
std::cout << "\nResult #2: ";
for (int i = 0; i < N; i++) // вывод в консоль побочной диагонали
{
std::cout << arr[i][N - 1 - i] << "\t";
}
return 0;
}
Объяснение: