решите на языке Питон Задача 5: Кинотеатр
В кинотеатре места часто расставляют со сдвигом соседних рядов для удобства зрителей. Пусть в таком кинотеатре N мест в 1-м, 3-м, 5-м и всех нечётных рядах и N + 1 место во 2-м, 4-м и всех чётных рядах. Места в рядах нумеруются от 1 до N в нечётных рядах и от 1 до N + 1 в чётных рядах.
Касса продаёт билеты подряд: сначала в 1-й ряд на места с 1-го по N-е, потом — во 2-й ряд на места с 1-го по N + 1-е, затем в 3-й ряд с 1-го места и т.д.
Определите номер ряда и номер места для K-го проданного билета.
Входные данные
Программа получает на вход два целых числа. В первой строке записано число N (1 ≤ N ≤ 109) — количество мест в 1-м ряду кинотеатра. Во второй строке записано число K — порядковый номер проданного билета (1 ≤ K ≤ 2×109).
Выходные данные
Программа должна вывести два числа: номер ряда и номер места K-го проданного билета.
Система оценивания
Решения, правильно работающие, когда входные числа не превосходят 1000, будут оцениваться в
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "");
int N = 10;
int max = -9999999;
int sum = 0;
int choise = 0;
int arr[N] = {0};
cout << "Введите 10 значений: ";
for(int i = 0; i<N; ++i) {
cin >> arr[i];
}
cout << "Введите действие (1 - +, 2 - макс. значение, 3 - колво отр. значений)";
cin >> choise;
if(choise==1) {
for(int i = 0; i<N; ++i) {
sum+=arr[i];
}
cout << endl << "Сумма: " << sum;
}
if(choise==2) {
for(int i = 0; i<N; ++i) {
if(arr[i]>max) {
max = arr[i];
}
}
cout << endl << "Макс. знач: " << max;
}
if(choise==3) {
for(int i = 0; i<N; ++i) {
if(arr[i]<0) {
++sum;
}
}
cout << "Колво отр. знач: " << sum;
}
if(choise!=1&&choise!=2&&choise!=3) {
cout << "Введите корректное значение.";
}
return 0;
}
ЯП: С++ | можно не писать std:: , если использовать пространство имен: using namespace std;
#include <iostream>
int main() {
const int SIZE = 10;
int regim, sum, max, count;
int arr[SIZE];
for (int i = 0; i < SIZE; i++)
{
std::cin >> arr[i]; // вводим элементы массива
std::cout << arr[i] << "\t"; // выводим массив в консоль
}
std::cin >> regim;
if ((regim > 0) && (regim < 4))
{
if (regim == 1)
{
for (int i = 0; i < SIZE; i++)
{
sum += arr[i]; // или sum = sum + arr[i];
}
std::cout << "Сумма элементов массива = " << sum << std::endl;
}
else if (regim == 2)
{
max = arr[0];
for (int i = 0; i < SIZE; i++)
{
if (max < arr[i])
max = arr[i];
}
std::cout << "Максимальный элемент в массиве = " << max << std::endl;
}
else
{
for (int i = 0; i < SIZE; i++)
{
if (arr[i] < 0)
count++;
}
std::cout << "Число отрицательных элементов в массиве = " << count << std::endl;
}
}
else
std::cout << "Доступен только 1-3 режим!" << std::endl;
return 0;
}