В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dianababitskay
dianababitskay
03.06.2021 23:58 •  Информатика

Решите сегодня на языке python Совпадающие начало и конец
Дана строка. Требуется найти самую длинную её подстроку, у которой совпадает первый и последний символы. Если подходит несколько подстрок, то выведите любую из них.

Входные данные

На вход подаётся одна строка из строчных латинских букв длиной не более 100 символов.

Выходные данные

Выведите ответ на задачу.

Показать ответ
Ответ:
ilyaronaldo
ilyaronaldo
14.04.2021 22:10

s = input()

ans = ''

for i in range(len(s)):

   j = s.rfind(s[i]) + 1

   if j - i > len(ans):

       ans = s[i:j]

print(ans)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота