В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Dodod616
Dodod616
05.12.2022 12:01 •  Информатика

Решите в python Пользователь вводит n чисел. Найти среднее арифметическое всех введённых чисел.
Ипполит задумал трёхзначное число, которое при делении на 15 даёт в остатке 11, а при делении на 11 даёт в остатке 9. Напишите программу, которая находит все такие числа.
Пользователь вводит с клавиатуры n чисел. Найти:

Произведение чётных чисел из последовательности;

Сумму нечётных чисел;

Количество положительных чисел

Показать ответ
Ответ:
VikiKot1315
VikiKot1315
11.01.2021 15:14
1.

n = int(input("Введите сколько чисел вы хотите ввести: "))

a = []

for x in range(1, n + 1):

   a.append(int(input("Введите число " + str(x) + ": ")))

s = 0

for x in range(0, len(a)):

   s += a[x]

print("Среднее арифметическое всех чисел:", s/len(a))

2.

print("Числа, которые задумал Ипполит: ")

for x in range(100, 1000):

   if x % 15 == 11 and x % 11 == 9:

       print(x)

3.

n = int(input("Введите сколько чисел вы хотите ввести: "))

a = []

for x in range(1, n + 1):

  a.append(int(input("Введите число " + str(x) + ": ")))

c = []

n = []

p = 0

for x in range(0, len(a)):

   if a[x] % 2 == 0:

       c.append(a[x])

   elif a[x] % 2 != 0:

       n.append(a[x])

   if a[x] > 0:

       p += 1

u = 1

s = 0

for x in range(0, len(c)):

   u *= a[x]

for x in range(0, len(n)):

   s += a[x]

print("Произведение четных чисел:", u)

print("Сумма нечетных чисел:", s)

print("Количество положительных чисел:", p)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота