В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
KingTheCat
KingTheCat
10.02.2022 23:25 •  Информатика

Решите в тетради , используя цикл while-wend 1. написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры. 2. написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).

Показать ответ
Ответ:
Vomaster228
Vomaster228
10.06.2020 19:07

using System;

namespace Interesting {
    class Program {
        static void Main() {
            float Max = 0;
            float Sum = 0;
            float N = 0;
            string s;
            float num;

            Console.WriteLine("Введите последовательность чисел. Для окончания введите пустую строку");
            try {
                while (true) {
                    Console.WriteLine("Введите число");
                    s = Console.ReadLine();
                    num = Convert.ToSingle(s);
                    Max = (num > Max) ? num : Max;
                    Sum += num;
                    N++;
                }
            }
            catch (Exception e) {
                Console.WriteLine("Ввод закончен");
            }

            Console.WriteLine("Максимальное = {0}, Среднее = {1}", Max, Sum / N);
        }
    }
}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота