В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Wogk
Wogk
30.11.2021 22:49 •  Информатика

Решите задачу в python быстрее!

— А разве ещё что-нибудь есть? — с надеждой с Пух, снова оживляясь.

Кролик заглянул во все кастрюли и банки и со вздохом сказал:

— Увы, совсем ничего не осталось.

— Я так и думал, — сочувственно сказал Пух, покачав головой. — Ну, до свиданья, мне пора идти.

Как вы помните, из этого ничего не вышло. Он застрял! А если отмотать события немного назад, сколько можно было съесть, чтобы все-таки пролезть в дверь?

Напишите программу, которая определит, на сколько единиц ещё можно увеличить объем Винни-Пуха, чтобы он не застрял.

Формат ввода
Целое число — на сколько единиц можно увеличить объем Винни Пуха, чтобы он ещё пролез в дверь. Затем строки мёд, сгущенное молоко или хлеб, пока не будет введена строка Ничего не осталось.

Формат вывода
Считая, что мёд увеличивает объем на 1 единицу, сгущённое молоко на две, а хлеб на три, вывести, сколько ещё единиц осталось до критического значения, или строку Не пролезает. Если значение оказалось равно критическому, то осталось 0 единиц, но всё ещё пролезает.

Пример 1
Ввод Вывод
7
мёд
сгущенное молоко
мёд
Ничего не осталось
3
Пример 2
Ввод Вывод
1
хлеб
Ничего не осталось
Не пролезает

Показать ответ
Ответ:
pastoling
pastoling
02.01.2020 21:07

{данная программа переводит любое сочетание символов ascii в систему счисления заданную пользователем.}

//pascal abc.net v3.0 сборка 1111

var

  a,i,b,r,n,j,bug: integer;

  s,se,slo,slof: string;

procedure preob(var a,b,n: integer; var se: string);

  begin

  repeat

    b: =a mod n;

    a: =a div n;

    str(b,se);

    s+=se;

  until (a< =n-1);

  end;

beginreadln(slo);

readln(n);

for j: =1 to length(slo) do

begin;

a: =ord(slo[j]);

preob(a,b,n,se);

str(a,se);

s+=se;

for i: =1 to length(s) div 2 do

begin;

se: =s[i];

s[i]: =s[length(s)-i+1];

s[length(s)-i+1]: =se[1];

end;

write(s,'-');

slof: =slof+s;

delete(s,1,length(s));

end;

end.

пример ввода:

работа на завтра.

2

пример вывода:

11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-

{таким образом, фразу " работа на завтра." можно закодировать как "11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-".}

0,0(0 оценок)
Ответ:
Angelina5353
Angelina5353
21.09.2020 16:36
Пользовательский интерфейс - это совокупность средств и правил взаимодействия человека и компьютера. взаимодействие человека и компьютера в наши дни строится на основе объектно-ориентированного графического интерфейса, в котором: все объекты представляются в виде значков; оперирование объектами осуществляется в окнах; основным элементом программного является меню; основным элементом аппаратного являются различные манипуляторы. информационное пространство пользователя - это информационные ресурсы (файлы с программами, документы, web-сайты, фотографии, видеофрагменты и доступные пользователю при работе на компьютере.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота