Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
тимур624
08.03.2022 16:36 •
Информатика
Реьят напишите программу вычисления выражения: s=1! +2! +3! ++n! используйте функцию вычисления факториала
Показать ответ
Ответ:
Соня12131415
23.09.2020 08:54
Var n,i,s:integer;
function fact(k:integer):integer;
var j,f:integer;
begin
f:=1;
for j:=1 to k do f:=f*j;
fact:=f;
end;
begin
write('n='); readln(n);
s:=0;
for i:=1 to n do s:=s+fact(i);
writeln('s=',s);
end.
Пример:
n=5
s=153
0,0
(0 оценок)
Ответ:
milka2851
23.09.2020 08:54
// PascalABC.NET 3.1, сборка 1198 от 11.03.2016
function F(n:Integer):integer:=Range(1,n).Aggregate(1,(i,j)->i*j);
begin
Writeln(Range(1,ReadInteger('n=')).Select(x->F(x)).Sum);
end.
Тестовые решения:
n= 5
153
n= 10
4037913
0,0
(0 оценок)
Популярные вопросы: Информатика
shevchenkok1
16.11.2021 10:13
Составьте программу,которая заменяет в строке s слоги ма на слоги бу...
zhanar7777
13.11.2021 14:43
Начав тренировки, лыжник в первый день пробегал 10 км. в каждый следующий день он увеличивал длину пробега на 10% от предыдущего дня. определить, в какой день он пробежит 20...
Matvey0203
23.04.2022 16:14
Програмисты ( pascal ) дана строка s и символ а. удвоить данный символ в строке (чтобы из 12ав получилось 1122аавв...
Aegon
26.03.2022 19:54
Выполни сложение: 112+1112 . ответ: 2...
али5553
01.05.2021 04:55
(av)(не d*b)) *((не a*(не bvd))vc)vне cv(av(b*не d))...
asanovaabibe20
12.11.2022 09:55
1) как происходит перевод крупных едениц измерения информация? и мелких? пример.2) как происходит перевод мелких единиц в крупные? привидите пример.3) определите информационный...
YaKuss
07.05.2023 04:15
Решите .желательно с обьяснением)...
Alyonaa201202
23.04.2023 15:08
Создать рисунок в графическом редакторе можно с инструментов:...
MariyKot
16.08.2021 14:26
Сграфического редактора изображение и его....
salsa555
16.08.2020 06:53
Пример слов которые можно читать в любом порядке...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
function fact(k:integer):integer;
var j,f:integer;
begin
f:=1;
for j:=1 to k do f:=f*j;
fact:=f;
end;
begin
write('n='); readln(n);
s:=0;
for i:=1 to n do s:=s+fact(i);
writeln('s=',s);
end.
Пример:
n=5
s=153
function F(n:Integer):integer:=Range(1,n).Aggregate(1,(i,j)->i*j);
begin
Writeln(Range(1,ReadInteger('n=')).Select(x->F(x)).Sum);
end.
Тестовые решения:
n= 5
153
n= 10
4037913