В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
polinavak05
polinavak05
21.10.2021 10:09 •  Информатика

С++ или си написать программу с комментариями что для чего, : функция delete(s,n,l) назначение: удаление из строки s подстроки, начиная с позиции n, длиной l (аналогичная библиотечная функция есть в pascal).

Показать ответ
Ответ:
makel200005
makel200005
04.10.2020 07:28
//Dev-C++ 5.11

#include <iostream>
#include <string>
using namespace std;

void DeleteStr(string&, int, int);

int main(void)
 {string s;
 int n,l;
 cin>>s>>n>>l;
 DeleteStr(s,n,l);
 cout<<s<<endl;
 return 0;}

void DeleteStr(string &s, int n, int l)
 {for(int i=n;i<s.length();i++) //начинаем удаление с n элемента
 if(i+l<s.length())  //проверка не выходит ли смещение за границы строки
  s[i]=s[i+l];   //если не выходит, просто переносим символ с позиции+l
 else
   s[i]='\0';      //иначе вводим на позицию пустой символ
}

Пример ввода:
Caster 1 4
Пример вывода:
Cr
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота