В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
fifi17
fifi17
11.01.2020 18:37 •  Информатика

с Информатикой: 1. Составить программу для нахождения среднего значения чисел последовательности кратных 6. Всего в последовательности 12 натуральных чисел, значения которых вводятся с клавиатуры.

2. Составить программу для нахождения разницы между наименьшей и наибольшей температуры за январь (31 день). Значение температуры вводится каждый день.

P.S. Найти на языке Pascal​

Показать ответ
Ответ:
ukraina3
ukraina3
14.11.2021 18:34
Function Otr(Ax, Ay, Bx, By: real): real;
begin
  Otr := sqrt(sqr(Ax - Bx) + sqr(Ay - By))
end;

function Perim(Ax, Ay, Bx, By, Cx, Cy: real): real;
begin
  Perim := Otr(Ax, Ay, Bx, By) + Otr(Bx, By, Cx, Cy) + Otr(aX, aY, Cx, Cy);
end;

function Area(Ax, Ay, Bx, By, Cx, Cy: real): real;
var
  pp: real;
begin
  pp := Perim(Ax, Ay, Bx, By, Cx, Cy) / 2;
  Area := sqrt(pp * (pp - Otr(Ax, Ay, Bx, By)) * (pp - Otr(Bx, By, Cx, Cy)) *
    (pp - Otr(Ax, Ay, Cx, Cy)))
end;

procedure Dist(Px, Py, Ax, Ay, Bx, By: real; var D: real);
begin
  D := 2 * Area(Px, Py, Ax, Ay, Bx, By) / Otr(Ax, Ay, Bx, By)
end;

var
  Px, Py, Ax, Ay, Bx, By, Cx, Cy: real;
  d: real;

begin
  writeln('Вводите координаты точкек парами чисел: ');
  write('P-> ');
  readln(Px, Py);
  write('A-> ');
  readln(Ax, Ay);
  write('B-> ');
  readln(Bx, By);
  write('C-> ');
  readln(Cx, Cy);
  writeln;
  Dist(Px, Py, Ax, Ay, Bx, By, d);
  writeln('Расстояние от Р до АВ равно ', d);
  Dist(Px, Py, Cx, Cy, Bx, By, d);
  writeln('Расстояние от Р до ВC равно ', d);
  Dist(Px, Py, Ax, Ay, Cx, Cy, d);
  writeln('Расстояние от Р до АC равно ', d)
end.

Тестовое решение:
Вводите координаты точкек парами чисел:
P-> -3 6
A-> 5 8
B-> 9 -4
C-> 8 -2.5

Расстояние от Р до АВ равно 8.22192191643778
Расстояние от Р до ВC равно 4.43760156980184
Расстояние от Р до АC равно 8.24163383692135
0,0(0 оценок)
Ответ:
LentaKuim
LentaKuim
25.04.2022 04:12

Вопрос 1.  ЭТ – это

 1)Прикладная программа, предназначенная для обработки структурированных  в виде таблицы данных

 

Вопрос 2. ЭТ предназначена для

 1)обработки числовых данных, представленных в виде таблиц

 

Вопрос 3. ЭТ представляет собой

 2)совокупность пронумерованных строк и поименованных буквами латинского языка столбцов

 

Вопрос 4. Строки ЭТ

  4)нумеруются

 

Вопрос 5. Столбцы ЭТ

  3)обозначаются буквами латинского языка

 

Вопрос 6. Для пользователя ячейка ЭТ идентифицируется

  3)путем последовательного указания имени столбца и номера строки, на пересечении которых располагается ячейка

 

Вопрос 7. Вычислительные формулы в ячейках ЭТ записываются

  2)специальным образом с использованием встроенных функций и по правилам, принятым для записи выражений в языках программирования

 

Вопрос 8. Выражение 3 (А1+В1) : 5 (2В1-3А2), записанное в соответствии с правилами,

                  принятыми в математике,  в ЭТ, имеет вид

  1)3* (А1+В1)/(5*(2*В1-3*А2))

 

Вопрос 9. Среди приведенных отыщите формулу для ЭТ

  4)=А3*В8+12

 

Вопрос 10. Запись формулы в ЭТ не может включать в себя

 4)текст

 

Вопрос 11. При перемещении или копировании в ЭТ абсолютные ссылки

  1)не изменяются

 

Вопрос 12. При перемещении или копировании в ЭТ относительные ссылки

  1)преобразуются в зависимости от нового положения формулы

 

Вопрос 13. Диапазон - это

  1)совокупность клеток, образующих в таблице область прямоугольной формы

 

Вопрос 14. Активная ячейка - это ячейка

  4)в которой выполяется ввод данных

 

Вопрос 15. Какая Формула будет получена при копировании в E4 формулы из Е2?

(если предположить, что в Е2 записано =$А$2*С2)

 3)=$A$2*C4

 

Вопрос 16. Какая Формула будет получена при копировании в E4 формулы из Е2?

 (если предположить, что в Е2 записано =$A$2*5)

    4)=$A$2*5

 

Вопрос 17. Какая Формула будет получена при копировании в E4 формулы из Е2?

  (если предположить, что в Е2 записано =A2*C2)

  4)=A4*C4

 

Вопрос 18. Чему будет равно значение в ячейке С1, если в нее ввести формулу =А1+В1?

  (если предположить, что в A1=10, B1=A1/2) 

  1)15

 

Вопрос 19. Чему будет равно значение в ячейке С1, если в нее ввести формулу

                      =СУММ(А1:В1)*2?

   (если предположить, что в A1=5, B1=A1*2)

  4)30

 

Вопрос 20. Сортировкой называют

 4)процесс линейного упорядочения некоторого множества

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота