В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
anyabelousova1
anyabelousova1
13.01.2021 01:02 •  Информатика

с Информатикой.
1)Задан массив X=[2, 4, 1,0,8,5], чему равно значение S после выполнения фрагмента программы?

S:= 0;
for k:=1 to N do begin
if x[k]>3 then
S:= S + X[k]
end;

2)Оператор:

for i:=1 to 20 do
if a[i]<>0 then writeln (a[i]);

выводит на экран:

Выберите один ответ:
a. цифру 0
b. положительные элементы массива а
c. ненулевые элементы массива а
d. отрицательные элементы массива а
3)Задан массив X[1..N] и фрагмент программы. Что вычисляет данная программа?

M:= X[1];
for k:=2 to N do begin
if x[k]>m then
M:= X[k]
end;

Выберите один ответ:
a. количество элементов массива, равных М
b. минимальное значение элементов массива
c. элемент массива, равный М
d. максимальное значение элементов массива
4)Задан массив X[1..N] и фрагмент программы обработки его. Что находит данный фрагмент программы?

S:= 0;
for k:=1 to N do begin
if x[i] mod 2=0 then
S:= S + 1
end;

Выберите один ответ:
a. Количество нечетных элементов массива
b. Количество четных элементов массива
c. Количество нулевых элементов массива
d. Сумму четных элементов массива

5)Выберите правильные варианты вывода элементов массива на печать в столбик (каждый элемент на новой строке).

Выберите один или несколько ответов:
a. for i:=1 to n do writeln(` a`,i,`=`,a[i]);
b. for i:=1 to n do write(a[i]);
c. for i:=1 to n do writeln(i);
d. for i:=1 to n do writeln(a[i]);

6)Задан массив X[1..N]. Какой оператор надо поставить вместо многоточия, чтобы найти в переменной S сумму всех элементов массива? Вводите ответ без пробелов.

S:= 0;
for k:=1 to N do begin
...
end;

Показать ответ
Ответ:
belovavaleriya
belovavaleriya
23.05.2021 14:35
За морями, за лесами, за высокими горами,
В компьютерном царстве, в компьютерном государстве
Жили были Единицы информации.
Хорошо они жили, не тужили,
Госпоже информации все верно служили,
Службой своей очень дорожили.
Каждая Единица имя имела,
Каждой было поручено своё дело.
И назывались единицы так:
Бит, Байт, Кб, Мб, Гб и Тб.
Как-то собрались Единицы информации все вместе
На жестком диске в файловом поместье.
И решили они устроить бал,
Чтоб народ их получше узнал.
Госпожа Информация эту идею поддержала
И своим Единицам такие наказы давала:
"Чтоб на бал не только сами пришли,
Но и друзей туда своих привели.
И пусть каждая про себя расскажет,
И себя и друзей своих покажет» .
И вот бал начинается
Много гостей на него собирается.
Сама Информация бал открывала,
При этом вид свой часто меняла.
И были у Информации виды такие:
Текстовые, графические, числовые,
На виды информации вы посмотрите,
Чудесные танцы их оцените.
отом Единицы стали выступать,
И про них можно много было узнать.
Как наименьшая Единица, первым выступил Бит
Два значенья он только хранит,
Ноль или Единицу
Двоичную Нулю сестрицу.
Обмен меж ними он ведёт
И песенку про них поёт.
«Если в Бите Ноль живёт
Единица тогда ждёт,
Когда Ноль уступит место
Ведь вдвоём им в Бите тесно. »
За Битом Байт был представлен
Основной Единицей он был объявлен.
За что же ему такая честь.
Что в нём особенного есть?
Послушаем, что Байт расскажет,
Каких друзей своих покажет.
«Восемь Битов Байт составят
И они его заставят
Превратиться в букву, в цифру
И в какой-то знак любой,
Как приказано им будет
Их любимой госпожой.
Байт - это символ и только один,
Но если мы Байты объединим,
То получим слово или число,
Смотрите, как много на бал их пришло.
Гостям про основную Единицу понятно»
И Байта послушать было приятно.
Следующим на балу объявляют Килобайта,
Чем отличается он от знакомого Байта.
Так, про себя рассказывает Кб:
"Я объединяю 1024 Байт.
И только в этом моё назначенье,
Удобно иметь побольше значенье.
Возьмём мы к примеру какой-нибудь файл,
Если будет объём его мал,
То в Байтах размер тогда выражается,
Для крупных - объём в Кб считается.
За Килобайтом идёт Мб
Он объединяет 1024 Кбт.
Мегабайт привёл на бал Память Оперативную
И рассказал историю почти детективную.
«Вся память раньше в Мб измерялась
Она всегда моей считалась,
Как вдруг, жесткий диск к Гб ушёл,
Потом и побольше приют он нашёл.
Уже в Тб жесткий диск измеряется,
Всё дальше он от меня удаляется,
Но я не в обиде, одна мы семья,
А в ней мы все большие друзья.
Станцует сейчас жесткий диск перед вами,
Что будет за танец посмотрите сами.
Вон там Гб с Тб стоят
И о себе они так говорят:
"Пока самые крупные Единицы - мы,
Но признаться Вам должны,
Что могут появиться ещё крупнее
Информация становится всё нужнее.
Ну а сейчас всем ясно стало,
Как информацию считать,
И какие Единицы, когда надо применять.
Единицы все о себе рассказали,
Гостей танцевать они приглашали,
И песенку хором все напевали.
«Единицы мы дружны, информации верны и считать её должны, .
Общее для нас важней, и ценней, и милей
Станем мы ещё дружней, веселей и нужней.
Все мы связаны друг с другом
И гордимся своим кругом.
Неразрывны, неразлучны,
Вместе нам совсем не скучно.
Будем мы Единство дружбой укреплять,
Информацию повсюду будем прославлять.
Не разлучит нас никто,
Все мы целое одно.
Единицы мы дружны, информации верны.
Полюбить вы нас должны, да должны.
Забывать про нас не нужно
Вы живите с нами дружно
Мы вам будем
Информацию считать
Биты, Байты, Килобайты
Перед вами здесь стоят
Мегабайты, Гигабайты
Дружно все вам говорят,
Что они стараться будут
Информацию считать
И ошибки в её счете
Ни за что не допускать
Ну а вы старайтесь тоже,
Ошибаться вам негоже
Дружно с нами вы живите
Нас получше изучите.
Вместе будем мы трудиться
Не захочется лениться
Никому и никогда
Труд нам радостен всегда.
Ну а сейчас наш бал завершается
Гости все по домам разъезжаются
Но Единиц информации они уже не забудут
И правильно использовать их будут.
Надеюсь что
0,0(0 оценок)
Ответ:
smail550
smail550
10.12.2022 16:32
Специально для вас выловил ошибки, находящиеся в предыдущем решении. Кому-то не повезло :(

//PascalABC
var
    S : array[1..10000] of integer;
    A, B, C, i, N, min : integer;
    W : real;
begin
    write('Укажите размер массива > ');
    readln(N);
    write('Вводите элементы массива > ');
    for i := 1 to N do
        readln(S[i]);
       
    A := 0;
    min := S[1];
    C := 0;
    for i := 1 to N do begin
        if S[i] > 0 then A := A + S[i];
        if S[i] < min then begin
            B := i;
            min := S[i];
        end;
        if S[i] mod 5 = 0 then C := C + 1;
    end;
    W := B + A / (C + 1);
    writeln('Сумма элементов ', A);
    writeln('Номер минимального эл-та ', B);
    writeln('Количество кратных пяти ', C);
    writeln('Параметр W ', W);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота