В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
gio8
gio8
16.06.2020 16:36 •  Информатика

с информатикой надо записать программу на паскале
кто понимает
буду очень благодарна

Рассматривается множество целых чисел, принадлежащих числовому отрезку [1529; 9482], которые удовлетворяют следующим условиям:
− запись в двоичной системе закачивается на 01;
− запись в пятеричной системе заканчивается на 3.
Найдите минимальное из таких чисел и их сумму. Гарантируется, что искомая сумма не превосходит 107.

Показать ответ
Ответ:
elen19871
elen19871
05.03.2021 22:25

var

i,a,j,k,b,s,counter : integer;

begin

s := 0;

counter := 1;

for i := 1529 to 9482 do

begin

j:= i;

k := i;

repeat a:= a*10+(j mod 2);

j:=j div 2;

until j=0;

repeat b:=k*10 + (k mod 5);

k:=k div 5;

until k=0;

if (a mod 100 = 01) and (b mod 10 = 3) then

begin

s := s + i;

if counter = 1 then

begin

counter := counter + 1;

writeln('Минимальное такое число:', i);

end;

end;

end;

writeln('Сумма чисел:',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота