В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
bobbobyashka1
bobbobyashka1
11.05.2020 19:08 •  Информатика

с информатикой. Составить программу на языке си:
Дан вещественный массив, состоящий из 67 элементов. Найти произведение положительных элементов, у которых порядковый номер элемента кратен 6. (Нумерация элементов массива начинается с нуля).

Показать ответ
Ответ:
gerczunt
gerczunt
15.05.2021 17:46

Вариант C:

#include <stdio.h>

#define SIZE 10

int main(void)

{

float result = 1;

float array[SIZE];

for(int i = 0; i < SIZE; ++i)

{

 scanf("%f", &array[i]);

 if(array[i] > 0 && (i % 6 == 0))

 {

  result *= array[i];

 }

}

printf("Произведение элементов, удовл. условию = %f", result);

return 0;

}

Вариант C++:

#include <iostream>

const int _size = 67;

int main()

{

float result = 1;

float arr[_size];

for(int i = 0; i < _size; ++i)

{

 std::cin >> arr[i];

 if(arr[i] > 0 && (i % 6 == 0))

 {

  result *= arr[i];

 }

}

std::cout << "Результат = " << result;

return 0;

}

Объяснение:

Проверяем элемент. Если он больше нуля и стоит на позиции, кратной 6, то добавляем в общее произведение.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота