В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Raydi1337
Raydi1337
13.07.2020 19:17 •  Информатика

с информатикой

А1. Что из нижеперечисленного не входит в алфавит языка Паскаль?

1) латинские строчные и прописные буквы,

2) арабские цифры,

3) русские строчные и прописные буквы,

4) знак подчёркивания.

А2. Какая последовательность символов может служить именем программы в языке Паскаль?

1) _test, 2) nos_56, 3) 56_ttt, 4)Игорь78.

А3. Обозначение целочисленного типа данных в языке Паскаль.

1) integer, 2) real, 3) char, 4) string.

А4. В результате выполнения фрагмента программы:

a:=3,14;

writeln (frac(a));

на печать будет выведено:

1) 14, 2) 3.14, 3) 3, 4) 3,14.

А5. В каком из условных операторов допущена ошибка?

1) if b=0 then writeln ( ‘Деление не возможно‘);

2) if a
3) if a>b then max:=a else max:=b;

4) if (a>b) and (b>0) then c:=a+b.

А6. В результате выполнения фрагмента программы

a:=5;

b:=20;

a:=a-b/2;

if a>b then c:=a+b else c:=b-a;

переменная с примет значение:

1) 25, 2) 14,5, 3) -15, 4) -14,5.

А7. Цикл во фрагменте программы :

a:=0.5;

s:=0;

i:=0;

repeat i:=i+1; b:=1/i; s:=s+a; until b
выполнится

1) 0 раз, 2) 2 раза, 3) 1 раз, 4) 4 раза.

А8. С оператора while в языке Паскаль программируется:

1) цикл - ПОКА, 2) цикл с параметром, 3) цикл – ДО, 4) все вышеперечисленные.

В заданиях группы Б представить полное решение или записать ответ.

Б1. Определите значение переменной b после выполнения фрагмента программы:

a:=4;

b:=3;

a:=12/a*b;

b:=a+b*2.

Показать ответ
Ответ:
190G
190G
23.09.2021 17:30

program Numfind;

uses

 System.SysUtils;

var

 a: array [1..10] of Integer;   // 1..10 размерность массива можно изменять, программа будет работать правильно

 i, s: Integer;

begin

 Randomize;

 for i := Low(a) to High(a) do

   a[i] := - 25 + Random (151);

 WriteLn ('Массив чисел:');

 for i := Low(a) to High(a) do

   Write (a [i], ' ');

 s := 0;

 WriteLn;

 WriteLn;

 WriteLn ('Выбрано: ');

 for i := Low(a) to High(a) do begin  // цикл выбора чисел больше 20

   if (a [i] > 20) then begin

     s := s + a [i];

     Write (A [i], ' ');

   end;

 end;

 WriteLn;

 WriteLn ('Сумма чисел больше 20 = ', s);

 s := 0;

 WriteLn;

 WriteLn ('Выбрано: ');

 for i := Low(a) to High(a) do begin  // цикл выбора чисел меньше 100

   if (a [i] > 0) and (a [i] < 100) then begin

     s := s + a [i];

     Write (A [i], ' ');

   end;

 end;

 WriteLn;

 WriteLn ('Сумма чисел меньше 100 = ', s);

 s := 0;

 WriteLn;

 WriteLn ('Выбрано: ');

 for i := Low(a) to High(a) do begin  // цикл выбора чисел кратных 3

   if (a [i] > 0) and (a [i] mod 3 = 0) then begin

     s := s + a [i];

     Write (A [i], ' ');

   end;

 end;

 WriteLn;

 WriteLn ('Сумма чисел кратных 3 = ', s);

 ReadLn

end.

0,0(0 оценок)
Ответ:
Bosik222
Bosik222
27.08.2020 17:10

свойства компьютера заменяет мозг человека вот професор был создал комп ты подошёл написал вопрос и ответ высветился эта главная цель компа обеспечет отдых мозгу человека и телу к пример хочеж узнать кто такой тигр не трать силы на поездку шёлк пик и готово 3д фильм тигр а есть 5д токо эта дорого подключаеш к телу костюм и на голову шлем и все ты засыпаеш костюм изменить сон ты сказал компьютершику хочу сон про то что я тигр вуале во сне тигр таймер проснулся и хвалиш 5д технологии за крутой сон ну и много секретных технологий есть комп эта круто

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота