В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Nakonechna21
Nakonechna21
09.07.2020 17:38 •  Информатика

С клавиатуры вводится строка, содержащая русские и латинские буквы. Составьте программу, которая определяет, каких букв больше. Программа для языка Pascal

Показать ответ
Ответ:
Нвдуооп
Нвдуооп
03.02.2022 10:10

Pascal:

var

str: string;

i, ENG, RUS: byte;

begin

writeln('Введите строку:'); readln(str);

for i := 1 to length(str) do

if upcase(str[i]) in ['A'..'Z'] then inc(ENG)

else if upcase(str[i]) in ['А'..'Я'] then inc(RUS);

if RUS > ENG then writeln('Русских букв больше на ', RUS - ENG)

else if ENG > RUS then write('Латинских букв больше на ', ENG - RUS)

else writeln('Одинаковое кол-во букв: ', RUS);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота