В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Krutoi0chuvak
Krutoi0chuvak
06.03.2021 22:43 •  Информатика

С клавиатуры вводится трёхзначное число. Составьте программу, выводящую на экран слово «Да», если его первая цифра чётная, и слово «Нет» в остальных случаях.

Показать ответ
Ответ:
rostikptashnik
rostikptashnik
07.05.2020 21:30

program zz1;

var n,n1,n2,n3:integer; //задаем переменные

begin

write('введите заданное трехзначное число');

read(n); //вводим с клавиатуры заданное трехзначное число

n1:=n div 100; //находим первую цифру числа

n2:=(n mod 100) div 10; //находим вторую цифру числа

n3:=n mod 10; //находим третью цифру числа

if (n1 mod 2 = 0)and(n2 mod 2 = 0)and(n3 mod 2 = 0) //проверяем, если все цифры четные, то выводим один ответ, если нет, то другой

then write('все цифры числа четные ') else write('некоторые цифры числа не четные');

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота