с контрольной по Информатике!
Контрольная работа «Разработка алгоритмов и программ»
1. Языковые конструкции с которых в программах записываются действия, выполняемые в процессе решения задачи, называются:
а) операндами; в) данными;
б) операторами; г) выражениями.
2. Что из нижеперечисленного не входит в алфавит языка Паскаль?
а) Латинские строчные и прописные буквы; в) знак подчеркивания;
б) русские прописные и строчные буквы; г) служебные слова.
3. Целые числа относятся к типу данных:
а) real; в) string;
б) integer; г) boolean.
4. Для ввода данных в Паскале используется оператор:
а) print; в) readln;
б) write; г) begin.
5. Для вычисления модуля числах х используется функция:
а) abs(x); в) int(x);
б) sqr(x); г) sqrt(x).
6. Определите значение переменной c после выполнения фрагмента программы:
a:= 60;
b:= 10;
a:= a - b*3;
if a 7. Используя следующие фрагменты составьте оператор цикла с условием.
а) a:=c+1; г) then;
б) for; д) do;
в) a>b; е) while.
8. В каком из условных операторов допущена ошибка?
а) if a б) if a>b then max:=a; else max:=b;
в) if b=0 then write (‘Деление невозможно’);
9. Определите значения переменной s после выполнения фрагмента алгоритма:
а)
s:= 0;
m:=6:
for i:=3 to m do
s:=s+i;
б)
s:=0;
i:=5;
while i>0 do
begin
i:=i-1;
s:=s+i;
end;
я сегодня добрый :) Первая задача.
var
s, mn: set of integer;
f: boolean;
k, n, c, i, j, kol: integer;
begin
writeln('Введите трехзначное число:');
repeat readln(n) until n in [100..999]; // защита от "дурака"
k := n; // записываем число, чтобы вывести на результат
while n <> 0 do
begin // пока число не станет равно нулю...
c := n mod 10; // последняя цифра числа
include(s, c); // вносим эту цифру в множество
n := n div 10 // у числа отсекаем рассмотренную цифру
end;
for i := 100 to 999 do
begin // рассматриваем все трехзначные числа
mn := s; j := i; f := true; // все обнуляем
while j <> 0 do
begin // пока рассматриваемое число не будет равно нулю
c := j mod 10; // последняя цифра числа
if c in mn then exclude(mn, c) else f := false; // если число во множестве, то убираем его оттуда, чтобы избежать повторений, иначе - не рассматриваем его.
j := j div 10; // у числа отсекаем рассмотренную цифру
end;
if f then begin inc(kol); write(i:6) end // если проверка успешно, то выводим число на экран и прибавляем значение переменной-счетчика!
end;
writeln; writeln('Из ', k, ' можно составить ', kol, ' чисел!'); // выводим результат
readln;
end.
А вот вторая, комменты к ней писать было уже лень:
var
k, i, n, kol: integer;
begin
writeln('Количество трехзначных чисел, которые вы далее введете?');
repeat readln(k) until k in [1..10];
for i := 1 to k do
begin
writeln('Введите ', i, ' трехзначное число:');
repeat readln(n) until n in [100..999];
while n <> 0 do
begin
if ((n mod 10) mod 2 = 0) then inc(kol);
n := n div 10;
end;
end;
writeln('Количество четных чисел = ',kol);
readln
end.
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
SeqGen(ReadInteger('k=')+1,2.0,x->2+1/x).Skip(1).Println;
end.
Тестовое решение:
k= 6
2.5 2.4 2.41666666666667 2.41379310344828 2.41428571428571 2.41420118343195
А теперь "школьный вариант":
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
var
i,k:integer;
a,a0:real;
begin
Write('k='); Read(k);
a0:=2;
for i:=1 to k do begin
a:=2+1/a0; a0:=a; Write(a,' ')
end
end.
Тестовое решение:
k=6
2.5 2.4 2.41666666666667 2.41379310344828 2.41428571428571 2.41420118343195