Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
mariael10
21.04.2022 13:58 •
Информатика
С++ написать функцию, выводящую в порядке возрастания элементы одномерного массива. в главной программе вызвать функцию для двух разных массивов.
Показать ответ
Ответ:
byxanceva6kv2
06.10.2020 02:39
#include <iostream>
#include <algorithm> // std::sort
using namespace std;
template <typename T>
void printSorted(T a[], int size)
{
sort(a, a + size);
for (int i = 0; i < size; i++) {
cout << a[i] << ' ';
}
cout << endl;
}
int main()
{
int ints[3] = {3, 2, 1};
double doubles[4] = {3.5, 2.6, 19.2, 8.1};
printSorted(ints, 3);
printSorted(doubles, 4);
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
ник5043
23.07.2022 15:20
Средний доход нужно вычислить.....
Цири
22.02.2020 15:28
Введите с клавиатуры два числа, найдите периметр и площадь прямоугольника. (линейные алгоритмы. язык паскаля)....
Vlad2005Mr
30.01.2021 06:27
Как называется работа или профессия которые обрабатывают текстовую информацию...
inchinusaozkhxs
30.01.2021 06:27
Перевести из восьмеричной системы счисления в двоичную 0,1467...
xokkey1
06.09.2022 20:14
#13 в некотором каталогехранился файл 5.doc. после того как в этом каталоге создали подкаталог и переместили в созданный подкаталог файл 5.doc, полное имя файла стало e: .doc....
MarinaSc1
11.01.2021 17:10
Как можно упростить эти выражения: не (не A) = не (не (не A)) = Как бы вы его назвали?...
daeinam095
04.04.2023 22:26
Розташуйте блоки у правильному порядку...
AyanaHaverfords
18.03.2023 08:21
Написать алгоритм в виде блок схемы в 6 действиях...
svetiksemisvetik2004
03.04.2023 10:21
Определите значение целочисленных переменных x, y и t после выполнения фрагмента программы: x : =5; y : =7; t : =x; x : = y mod x; y : = t;...
Poli2533
03.04.2023 10:21
Преобразуйте число 111011.10011 2 в шестнадцатиричную систему счисления.переведите число 32,25(10) в восьмеричную систему счисления....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <algorithm> // std::sort
using namespace std;
template <typename T>
void printSorted(T a[], int size)
{
sort(a, a + size);
for (int i = 0; i < size; i++) {
cout << a[i] << ' ';
}
cout << endl;
}
int main()
{
int ints[3] = {3, 2, 1};
double doubles[4] = {3.5, 2.6, 19.2, 8.1};
printSorted(ints, 3);
printSorted(doubles, 4);
return 0;
}