В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
KingTheCat
KingTheCat
01.04.2023 19:14 •  Информатика

С++ написать программу для создания массива записей (структур) со сведениями о студентах: фио, возраст, курс, успеваемость. успеваемость – это оценки студента по 3 предметам. ввод-вывод информации и другие необходимые алгоритмы (согласно ) реализовать в виде функций. по заданному массиву определить: определить количество неуспевающих студентов по m предмету на n курсе.

Показать ответ
Ответ:
Ka4erga3000
Ka4erga3000
28.10.2022 01:24
Шупашкар Чăваш Республикин тĕп хули. Шупашкарта пĕтĕмпе 460,2 пин çын (2002 çулхи халăх çыравĕ тăрăх) пурăнать. Шупашкар Чулхулапа Хусан хулисем хушшинче, Атăл юханшывăн сылтăм çыранĕнче вырнаçнă. Шупашкар виçĕ района пайланать: Калинин районĕ, Ленин районĕ, Мускав районĕ тата Атăл лешьенчи çĕр тытăмĕ. Шупашкартан инçех мар хула-спутникĕ Çĕнĕ Шупашкар вырнаçнă. Унта пĕтĕмпе 125 пин çын пурăнать. Шупашкар кунĕ: çурла уйăхĕн виççĕмĕш вырсарникунĕ. Шупашкар хулинчен аякрах мар Атăл тăрăх кайсан Çĕнĕ Шупашкар, Сĕнтĕрвăрри, Куславкка хулисем вырнаçнă.
0,0(0 оценок)
Ответ:
Ramiz2005
Ramiz2005
06.05.2020 03:15
#генерируем список из 2000 элементов
my_list = [(lambda x:(x*296+2410)%4096)(i) for i in range(2000)]

# начальное значение для временного минимума
min1_value = min2_value = 10000
min1_number = min2_number = 0

while my_list:
    x = my_list.pop()
    if x < min1_value:
        min2_value = min1_value
        min2_number = min1_number
        min1_value = x
        min1_number = 1
    elif x == min1_value:
        min1_number += 1
    elif x < min2_value:
        min2_value = x
        min2_number = 1
    elif x == min2_value:
        min2_number += 1
        
print(min2_number)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота