В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
foltes
foltes
06.05.2020 18:20 •  Информатика

с ! Напишите программу для подсчета количества дней, в которых температура была не ниже, чем средняя температура за весь период. В первой строке вводится список показателей температуры на каждый день. В строке вывода одно число - количество дней, которые соответствуют условию.

К примеру, Ввод:
-3 -1 0 2 6 8 12 15
Вывод:
4

Показать ответ
Ответ:
LeraBelenko
LeraBelenko
09.07.2021 01:51

massiv=input()

massiv=list(map(int,massiv.split(" ")))

sr=sum(massiv)/len(massiv)

count=0

for i in range(len(massiv)):

   if massiv[i]>=sr:

       count+=1

print(count)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота