В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Sawa1605
Sawa1605
12.01.2020 07:30 •  Информатика

С++ напишите программу, которая выводит на экран все цифры числа, начиная с первой. допустим, вводишь 123, а программа выводит 1 2 3.

Показать ответ
Ответ:
maxkostin29rus
maxkostin29rus
08.10.2020 02:00
Один из простых методов.
#include <iostream>
void digits(const unsigned &val)
{
    if (val) {
        std::cout << (digits(val / 10), val % 10) << "  ";
    }
}
int main()
{
    digits(123);
    return 0;
}
0,0(0 оценок)
Ответ:
cyganka84
cyganka84
08.10.2020 02:00
#include <iostream>
#include <stack>

using namespace std;

void digits(int *num);

int main()
{
    int num;
    cin >> num;
    void(*ptr)(int *num);
    ptr = digits;
    (*ptr)(&num);
    return 0;
}
void digits(int *num)
{
    stack<short int> stack;
    while(*num>0)
    {
        stack.push(*num % 10);
        *num /= 10;
    }
    while(!stack.empty())
    {
        cout << stack.top() << " ";
        stack.pop();
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота