В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mru199
mru199
29.06.2022 12:56 •  Информатика

с паскалем Дан целочисленный массив A(20) необходимо найти среднее арифметическое по модулю <9 ​

Показать ответ
Ответ:
coopersmith
coopersmith
27.02.2022 17:31

Объяснение:

C++Выделить код

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

39

40

41

42

43

44

45

46

47

48

49

50

51

52

53

54

55

/*

*Лабораторная работа: 7.

*Тема: Строки и файлы. Организация работы со строками и файлами.

*Пункт: 5.2. Файловый тип данных.

*Файл: Lab07_YaP_2019_1S.pdf

*

*Язык: C++.

*Среда: Microsoft Visual Studio 2019 v16.3.0.

*Платформа: x64.

*Изменение: 06.01.2020.

*

*Вариант: 13.

*Защита: 15.11.2019.

*Задание: БН. Написать программу, которая считывает Английский текст из файла и выводит его на экран, заменив каждую первую букву слов,

*     начинающихся с гласной буквы, на прописную.

*/

#include <iostream>                                                        // Треб. для SETLOCATE, PRINTF, GETLINE, STRLEN, CIN, COUT. //

#include <fstream>                                                         // Требуется для FSTREAM. //

#include "Header.h"

void main () {

    setlocale (LC_ALL, "Russian");

    char SourceArray [Dimension + 1] = " ";                               // SOURCEARRAY [100] = 101 (для "\0"). //

    char LettersArray [Dimension - 72] = " ";                             // [0]..[25] = 1..26 (для ввода с клавиатуры), [26] = 27

    char PathTextFile [Dimension + 1] = " ";                              // (для "\0"). //

    printf ("1. Латинский алфавит (26 букв): a, b, c, d, e, f, g, h, i, j, k, l, m, n, o, p, q, r, s, t, u, v, w, x, y, z.\n\n2. Введите"

         " путь и имя файла (до %d символов, включительно): ", Dimension);

    cin.getline (PathTextFile, Dimension);

    fstream TextFile (PathTextFile, ios::trunc | ios::in | ios::out);     // TRUNC - создание, IN - режим записи, OUT - режим чтения. //

    if (!TextFile) {

         MessageFunction ();                                              // Выводится на экран, если файл открыть не удалось. //

    }

    printf ("\n3. Введите строчные Латинские буквы, которые следует заменить на прописные (до %d символов, включительно):\n\n",

         Dimension - 73);

    cin.getline (LettersArray, Dimension - 72);

    if (strlen (LettersArray) < 1) {

         TextFile.close ();                                               // Закрытие файла. //

         MessageFunction ();

    }

    printf ("\n4. Введите строку (до %d символов, включительно):\n\n", Dimension);

    cin.getline (SourceArray, Dimension);

    if (strlen (SourceArray) < 1) {

         TextFile.close ();                                               // Закрытие файла. //

         MessageFunction ();

    }

    TextFile << SourceArray;                                              // Запись SOURCEARRAY в файл. //

    TextFile.close ();                                                    // Закрытие файла. //

    ChangeFunction (LettersArray, PathTextFile);

    printf ("\n5. Исходная строка после замены:\n\n");

    WriteArrayFunction (PathTextFile);

    remove (PathTextFile);                                                // Удаление файла. //

    cout << endl << endl;

    ExitProgramFunction ();

}

0,0(0 оценок)
Ответ:
Samoilov2903
Samoilov2903
22.05.2020 12:08

В 1623 году Вильгельм Шиккард придумал «Считающие часы» — первый арифмометр, умевший выполнять четыре арифметических действия. Считающими часами устройство было названо потому, что, как и в настоящих часах, работа механизма была основана на использовании звёздочек и шестерёнок. Это изобретение нашло практическое использование в руках друга Шиккарда, философа и астронома Иоганна Кеплера.

За этим последовали машины Блеза Паскаля («Паскалина», 1642 г.) и Готфрида Вильгельма Лейбница — арифмометр Лейбница.

Лейбниц также описал двоичную систему счисления — один из ключевых принципов построения всех современных компьютеров. Однако, вплоть до 1940-х многие последующие разработки (включая машины Чарльза Бэббиджа и даже ЭНИАК 1945 года) были основаны на более сложной в реализации десятичной системе.

В 1820 году Шарль Ксавье Тома де Кольмар создал первое серийно выпускавшееся механическое счётное устройство — арифмометр Томаса, который мог складывать, вычитать, умножать и делить. В основном, он был основан на работе Лейбница.

В 1845 году Израиль Штаффель представил счётную машину, которая кроме четырёх арифметических действий могла извлекать квадратные корни. Арифмометры, считающие десятичные числа, использовались до 1970-х.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота