с паскалем!
Напишите программу, которая в последовательности натуральных чисел определяет количество всех чётных чисел, кратных 9. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество всех чётных чисел, кратных 9.
ответ: Що таке предметна галузь?
Ти вже знаєш, що нас оточують різні об’єкти. Кожен об’єкт має свої властивості та їх значення — дані різного типу. Об’єкти, що мають однакові властивості, можна об’єднувати в групи — класифікувати. З об’єктами також можна виконувати певні дії. Крім того, різні об’єкти взаємодіють між собою: планети утворюють Сонячну систему, моле- кули утворюють різні сполуки, учні та вчителі взаємодіють у школі. Сукупність об’єктів, що мають однакові властивості та перебувають у певних відношеннях, утворюють предметну галузь. Предметними галузями можуть бути, наприклад, архітектура, про- мислове підприємство, транспорт, освіта тощо.
Предметна галузь — сукупність всіх об’єктів, властивості яких і відношення між якими розглядаються у відповідній галузі.
Предметну галузь часто називають галуззю дослідження, об- ластю вивчення чи колом інтересів. В англійській мові це Field of Study. Одну й ту саму предметну галузь можуть досліджувати люди різних професій чи віку. При цьому вони виділяють об’єкти з цієї галузі чи розглядають різні властивості об’єктів залежно від завдання, яке ви- конується. Наприклад, предметну галузь біологія можуть розглядати учні на уроках, науковці в лабораторіях чи дослідники-мандрівники в реальних умовах.
Чому люди користуються моделями та створюють їх?
Об’єкти, що оточують людину, належать до різних предметних га- лузей і є досить складними. Деякі реальні об’єкти досліджувати в пов- ній мірі складно. Наприклад, без додаткового сучасного обладнання неможливо провести наукові дослідження з об’єктами, що перебувають на значній відстані, зокрема, з космічними, з дуже малими або дуже великими
об’єктами. Саме тому часто реальні об’єкти замінюють їх моделями. При розв’язуванні кожної конкретної задачі людину мо- жуть цікавити лише деякі з властивостей, тоді говорять про суттєві властивості об’єктів.
Наприклад, якщо ви з одно- класниками вирішите висадити на шкільному подвір’ї квітковий го- динник, то суттєвими властивостя- ми об’єкта квітка будуть: розмір, час цвітіння, час розкривання та закривання квітів. Але якщо доби- ратимете квіти для гербарію, то вас цікавитимуть зовсім інші властиво- сті: збереження кольору квітки після сушіння, ступінь усушки тощо. На основі даних про властивості, що є суттєвими в конкретній си- туації, можна створити інший об’єкт, який спрощено відображатиме основні властивості реального. Такі спрощені об’єкти називають моде- лями
Объяснение:
ответ:Program a10;
var a,b:Array [1..100,1..100] of integer;
k,i,n,j,s:integer;
Begin
read(n);
For i:=1 to n do
begin
For j:=1 to n do
begin
read(a[i,j]);
end;
end;
i:=0;j:=0;s:=0;k:=0;
while i<=n do
begin
i:=i+1;j:=j+1;
if(a[i,j]>0)then k:=k+1;
s:=s+a[i,j];
end;
writeln(k,' ',s);
end.
2)
Program a10;
var a,b:Array [1..100,1..100] of real;
k,i,n,m,j:integer;
s:real;
Begin
read(n,m);
For i:=1 to n do
begin
For j:=1 to m do
begin
read(a[i,j]);
end;
end;
k:=0;
for j:=1 to m do
begin
s:=0;
for i:=1 to n do
begin
s:=s+a[i,j];
end;
for i:=1 to n do
begin
if(a[i,j]>(s-a[i,j]))then k:=k+1;
end;
end;
writeln(k);
end.
Объяснение: