В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
onpapion
onpapion
03.02.2022 22:08 •  Информатика

с программой, даже условие не могу понять хотя-бы натолкнуть на мысль Условие
Напишите функцию, которая как результат будет возвращать подпоследовательность элементов массива, начиная с позиции X до позиции Y включительно в обратном порядке с шагом Z как новый массив. По умолчанию шаг должен быть равен 1.

Ваша задача для заданного массива вывести срез с шагом 1 и с шагом, заданным с клавиатуры.

Формат входных данных
В первой строке задается натурально число N, (N ≤ 10000)- размер массива.

В следующей строке вводятся N целых чисел, по модулю не превосходящих 109 - элементы массива.

В последней строке вводятся три целых числа X, Y и Z (0 ≤ X ≤ Y < N, 0 < Z < N)- границы и шаг среза соответственно.

Формат выходных данных
В первой строке выведите перевернутый фрагмент массива с шагом 1.

Во второй строке выведите перевернутый фрагмент массива с шагом Z.

Показать ответ
Ответ:
Dima25688
Dima25688
03.12.2020 14:10

#include <iostream>

#include <vector>

 

using namespace std;

 

void srez(vector<int> arr, int x, int y, int z = 1) {

   for (int i = y; i >= x; i -= z) {

       cout << arr[i] << ' ';

   }

   cout << '\n';

}

 

int main() {

   int n;

   cin >> n;

   vector<int> arr(n);

   for (int i = 0; i < n; ++i) cin >> arr[i];

   int x, y, z;

   cin >> x >> y >> z;

   srez(arr, x, y);

   srez(arr, x, y, z);

   return 0;

}

Писал код сам, тоже по этой задаче С++

0,0(0 оценок)
Ответ:
Theboss007
Theboss007
03.12.2020 14:10

wog18303

сейчас

Информатика

1 - 4 классы

+18 б.

ответ дан

с программой, даже условие не могу понять хотя-бы натолкнуть на мысль

Условие

Напишите функцию, которая как результат будет возвращать подпоследовательность элементов массива, начиная с позиции X до позиции Y включительно в обратном порядке с шагом Z как новый массив. По умолчанию шаг должен быть равен 1.

Ваша задача для заданного массива вывести срез с шагом 1 и с шагом, заданным с клавиатуры.

Формат входных данных

В первой строке задается натурально число N, (N ≤ 10000)- размер массива.

В следующей строке вводятся N целых чисел, по модулю не превосходящих 109 - элементы массива.

В последней строке вводятся три целых числа X, Y и Z (0 ≤ X ≤ Y < N, 0 < Z < N)- границы и шаг среза соответственно.

Формат выходных данных

В первой строке выведите перевернутый фрагмент массива с шагом 1.

Во второй строке выведите перевернутый фрагмент массива с шагом Z.

1

СМОТРЕТЬ ОТВЕТ

ДОБАВИТЬ ОТВЕТ

Спросите wog18303 о заданном вопросе...

wog18303 ждёт твоего решения.

ответь на вопрос и заработай .

ответ

5,0/5

1

slysnenko

хорошист

34 ответов

469 пользователей, получивших

#include <iostream>

#include <vector>

using namespace std;

void srez(vector<int> arr, int x, int y, int z = 1) {

for (int i = y; i >= x; i -= z) {

cout << arr[i] << ' ';

}

cout << '\n';

}

int main() {

int n;

cin >> n;

vector<int> arr(n);

for (int i = 0; i < n; ++i) cin >> arr[i];

int x, y, z;

cin >> x >> y >> z;

srez(arr, x, y);

srez(arr, x, y, z);

return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота