В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sarinasergeeva
sarinasergeeva
23.09.2022 06:48 •  Информатика

с рекурсией на Си. Нужно составить программу, которая с рекурсивного алгоритма находит произведение цифр кратных трем в числе.​

Показать ответ
Ответ:
aadfgjrv
aadfgjrv
21.07.2022 07:32

Математическая модель (а также программа; зависит от того, что понимать под этапом формализации).

В учебнике выделяют такие этапы решения задачи на компьютере:

Исходные данные (результат - словесная информационная модель)Формализация (математическая модель)Алгоритмизация (алгоритм)Программирование (программа)Отладка, тестирование (уточнение модели)Выполнение расчетов (получение результатов)

Нормальные люди понимают, что после формализации информация должна быть представлена на формальном языке, таких языком может быть как математический, так и язык программирования.

0,0(0 оценок)
Ответ:
StEInN2
StEInN2
24.02.2021 00:04
Const n=8;
var x : array[1..n] of real;
   i : integer; min : real;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
  x[i]:=20*random-10;
  write(x[i]:6:2,' ');     
 end;
 writeln;
min:=x[1];
for i:=2 to n do
 if x[i] < min then min:=x[i];
writeln('min=',min:6:2);
for i:=1 to n do
 if x[i]<0 then x[i]:=min;
writeln('Измененный массив:');
for i:=1 to n do write(x[i]:6:2,' ');
end.

Пример:
Исходный массив:
 -7.84  -9.97   7.00  -8.26  -7.71  -3.88   7.59  -2.32 
min= -9.97
Измененный массив:
 -9.97  -9.97   7.00  -9.97  -9.97  -9.97   7.59  -9.97 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота